Servers by jDrones

3.6.0 RC12 Kakute F7 AIO Baro: unable to initialise driver


(Jonathan Riches) #1

Trying to use Arducopter on a Kakute F7 AIO for the first time. Tested it first on Betaflight, then flashed 3.6.0 RC12, comes up with…

Frame: QUAD
KakuteF7 0039001D 34365107 31393931
ChibiOS: ff603d11
ArduCopter V3.6.0-rc12 (014022de)
Check BRD_TYPE: Baro: unable to initialise driver

Which then loops. What am I missing?

Thanks for your help

Jonathan


(rmackay9) #2

@jon_hfd,

I’m not too familiar with the F7 (we haven’t added it to our wiki yet it seems). i think you’ll need to add an external barometer. I’ve successfully done this with a pixhawk but not a Kakute.


(Jonathan Riches) #3

Thanks, the Kakute has a barometer, and it’s working fine on Betaflight. No compass, but I’ve already added one with the GPS. Others seem to have had the Kakute working OK previously.

I’ve been wondering, is there any possibility that a problem with the Windows drivers could mean it could read enough to get the board, but not the sensors? (even though it works OK on Betaflight)

Thanks

Jonathan


(Paul Atkin) #4

Hi, i will try to pull rc12 today and test. Baro should work fine. R u sure you got correct file to flash?
I compile my own builds but rc12 uses same hwdef file i am using.


(Paul Atkin) #5

ok, here is the file i am flashing:
http://firmware.ardupilot.org/Copter/beta/KakuteF7/
arducopter.apj

with the MP software as i already have a bootloader there.

for a brand new board one would need to start betaflight software and flash in this file: arducopter_with_bl.hex

I did this all in real time - here is the printout of board starting:
PreArm: Need 3D Fix
PreArm: Throttle below Failsafe
u-blox 1 HW: 00080000 SW: EXT CORE 3.01 (107900)
PreArm: Need 3D Fix
PreArm: Throttle below Failsafe
Frame: QUAD
KakuteF7 003C003A 34345117 39383339
ChibiOS: ff603d11
ArduCopter V3.6.0-rc12 (014022de)
EKF2 IMU0 tilt alignment complete
EKF2 IMU0 initial yaw alignment complete
GPS 1: detected as u-blox at 115200 baud
Barometer calibration complete
Initialising APM

all works fine. Pls double check what file you have flashed.


(Jonathan Riches) #6

Brilliant, thanks, I’ll give that a go and report back


(Paul Atkin) #7

just to be sure i also did something i did not want to do :slight_smile: - my allother models were made on the Kakute f7 AIO FC.
I am making one model now on the Owl frame with the Kakute F7 board hooked up with 4in1 ESC from holibro - that $125 stack with atlant and tekko32.

i just flashed it with the .hex file from rc12. it loaded perfectly -

EKF3 IMU0 tilt alignment complete
EKF3 IMU0 initialised
EKF3 IMU0 buffers, IMU=19 , OBS=7 , dt=0.0120
Initialising APM
Barometer calibration complete
Frame: QUAD
KakuteF7 00250033 32365101 30383430
ChibiOS: ff603d11
ArduCopter V3.6.0-rc12 (014022de)
Calibrating barometer


(Paul Atkin) #8

ok, and now i think i have quite an interesting empirical evidence. do not want to do more tests on it for now, but - as i have flashed in an arducopter .hex file with betaflight - i was able to press DFU button on the kakute board and it went into the DFU mode with no issues and i just flashed back betaflight into it.

i do suspect that if one tried to flash new or altered .apj file with MP into Kakute - something in it goes kaput and board stops entering into DFU mode upon pressing a button - it has happened to my new AIO board that i also was able initially to flash into the arducopter and back into the betaflight.

so, if one only flashes .hex file it seems to work and this way it can be flashed back and forth if you want to compare how model will work on different code.

when you flash it - make sure to solder RCIN to the uart 6 RX. uart6 TX is also active and can be used for one way out - you can set it to pump out telemetry or anything that is a one way TX stream.

i am still having issues with uart7 for ESC telem - but will test more this weekend. it should work.

LED is not used. buzzer produces proper tones but will probably whistle upon power up until code loads as bootloader was never adjusted to put that pin into high state.


(Paul Atkin) #9

ok, stop using that rc12 file for kakute!!!

i do not know how it is possible but it has wrong motor pins in there. either somebody replaced hwdef or something else has happened. i need to sort it out now. i just tried to tune motors on rc12 and motors 1 and 2 did not work - it was like that on the initial hwdef that was later replaced with one from my fork.

i am not sure what is that about yet.


(Jonathan Riches) #10

Ok, thanks
I just flashed it, but seem to have driver problems when not in DFU mode, must have got something wrong.
What drivers are you using? I downloaded the STM ones, then used Impulse RC Driver Fixer.
ps I don’t think I mentioned that mine is the AIO, not the normal one


(Paul Atkin) #11

hmm, i am not sure what do you mean? can you connect to it with betaflight? or you cannot connect to it with MP?

i am going to check now hwdef in the master - i think rc12 fork has a wrong hwdef.


(Jonathan Riches) #12

Ok, so I’ve wiped out all the drivers and started again, installed ST VCP, used Zadig to get DFU back. Can now both flash and get Betaflight to work fine. On BF everything works, Baro, Mag, GPS, etc.

Just for the sake of testing I flashed 3.6.0 RC12, I can connect ok, but still get the Baro error as per my OP.


(Paul Atkin) #13

this is more than odd.
are you absolutely positive you flashed this file?
http://firmware.ardupilot.org/Copter/beta/KakuteF7/arducopter_with_bl.hex
?

when did you buy that kakute and where from? again, it is not an AIO - it is a regular kakute f7? as i flashed it with this file this morning and i got mine 1 week ago. baro was never altered on those boards. if yours is not found and you used correct file - it means your I2C bus is not coming up and it is insane.
i can give you my .apj file to flash with MP but i am afraid it will be a point of no return for you as board will not flash back to betaflight.


(Jonathan Riches) #14

Mine is an AIO, have I got the wrong file?


(Paul Atkin) #15

no
they are same. all my other models are on AIO and i used same exact hwdef for both.let`s wait on that, i suspect rc12 used wrong hwdef file. may be.


(S) #16

Is it possible they changed the hardware?


(Paul Atkin) #17

highly unlikely.
ok.
please download and flash with betaflight this file:

http://firmware.ardupilot.org/Copter/latest/KakuteF7/arducopter_with_bl.hex


(Jonathan Riches) #18

Sure it was the right one, but just in case I’ve just downloaded from your link again, just reflashing now.

Mine was from Banggood, received a few days ago. I know since the very first ones they fixed the boot button not entering DFU issue, but assume the rest should be the same


(Jonathan Riches) #19

Ah, thanks Paul, will try that one


(Paul Atkin) #20

if that does not work we will need to talk to Randy and tridge to understand what is the deal.
it uses latest master and this file below

is identical to one i have in my build.

if they have changed the hardware- it is theoretically possible, of course, but, gosh, that would mean a different baro? not sure. i can write them and ask but it is highly unlikely.