3.5.0-RC2 On Heli with Pixracer- Can't Clear Motor Interlock (Solved)

This is a new setup of a real Pixracer from AUAV stuck to a heli :scream: Accel, compass, voltage current, and RC calibrated. Servo 1 channel reversed. SERVO5_FUNCTION=31 for my HeliRSC. I can’t clear the Prearm: Motor Interlock Enable.

I then setup CH7_OPT=32 for enabling the interlock. All other CHx_OPT’s are 0. Again calibrated my radio to include ch7. Still no change with the channel high. Also check low for the heck of it. What am I missing?

BTW: No external FBL controller like the Microbeast. I read that some folks use both but don’t understand why. I took mine off and was the purpose of this new project.

What H_RSC_Mode are you using?
I believe that in order for the Prearm warning to clear, you need to have the minimum pwm out value to be close to the pwm min for the channel. I can’t recall where I read this :/.

I have my H_RSC_mode set to 2 and use a switch (and govn’d ESC) to control the throttle and had to make sure that min PWM output was close to the min PWM on the channel:
http://ardupilot.org/copter/docs/traditional-helicopter-configuration.html#mode-2-h-rsc-mode-set-to-2
http://ardupilot.org/copter/docs/parameters.html#rc8-min-rc-min-pwm

H_RSC_MODE = 1. H_RSC_PWM_MIN = 1000. Actual value 982. So I’m below the min but will lower the 1000 more and test.

I lowered the min to 983 and 982 with hawk reboots in between and also changed mode from 1 to 2 but still have the interlock. All my RCx_MIN are reset to the actual min’s after a RC calibration so RC5_MIN is set to 982.

I know almost nothing about helis so bear with me on this.

  • About needing to use interlock, here is a comment in code:

https://github.com/ArduPilot/ardupilot/blob/master/ArduCopter/AP_State.cpp#L107

  • Do you have interlock in disabled position?
  • Is your RC8 input channel at the minimum?
  • I see you talking about RC5_MIN, you know that is the channel that controls modes right?

I hope those points can help in some way.

Thanks OXINARF. I will.

  • I have interlock enabled (High) using ch7. Looks like from the comment it is a requirement for helis.
  • I have set SERVO8_FUNCTION to 0 and SERVO5_FUNCTION to 31 for HeliRSC. The Pixracer only has 6 PWM outputs. It is at 982.
  • Yes fight modes. I should have been looking at SERVO5_MIN which I just changed from 1100 to 982, no change.

I can’t say with certainty but it looks like you need to have it configured (like you did with CH7_OPT) but disabled to arm.

Sure, that’s for output. From my understanding you control the main rotor with input channel 8, so that needs to be at the minimum too - that’s what I was asking.

I’m not sure if related or not, but a bug was found (and fixed) on loading Heli parameters (https://github.com/ArduPilot/ardupilot/pull/5866). The fix will go out with RC3 shortly.

For not knowing much about helis you came through again. My head was still wrapped around FBL controllers where they extract the throttle from the collective pitch signal on input ch3. After reading what you wrote then reading again about H_RSC_MODE I assigned a Tx switch to Ch 8. I also removed the CH7_OPT (set back to 0) and now I can arm and start my rotor. Thanks man!!

Solved: Assign a Tx Switch to Ch 8

Glad I could help! I can see how heli code will take care of disabling interlock for you. It’s great you got it all working as you want :slight_smile: