Pixracer setup for Heli


I’m trying to use a Pixracer on Heli and found that CH8 is needed to control the motor ESC(PIxracer have only 6 servos channels).

Reading the following thread, I can see that it is possible…


Now I’m facing two problems:

  1. How to configure \ set the Pixracer to control the throttle not using CH8 (parameters setup)?
  2. Tail servo is not response to RC

Please your advise
Thank you very much

1 Like

Please post a param file. Thanks!

Hello Bill,

Thank you for replay.

Please see attached.

RotemPixracer Heli.param (13.3 KB)

Thanks for the param file. This will help me see what you have so far. Although the poxracer has limited outputs, what type of transmitter are you using. The channel that the ESC is connected to does not have to be channel 8 and is assigned with the SERVOX_FUNCTION parameter. You can set this to channel 5 or 6 coming out of the pixracer. You do this by setting the respective SERVO_FUNCTION parameter to 31.
So the key to getting this working on the transmitter side is having a 7 or 8 channel transmitter and receiver. If you have a 7 channel then you could only use the RSC mode 2 or 3. The passthrough or RSC mode 1 requires that you have a channel 8 because the code is such that it only reads the passthrough on channel 8.
If you have an 8 channel transmitter and receiver then you don’t have to use the ch8_opt parameter. If you only have 7 channels then you will have to set the ch7_opt parameter to 32 in order to enable motor interlock which will also activate your ESC (but only if set up for mode 2 or 3).
Hopefully this all makes sense.

Hello Bill,

Thank you very much for the detailed explanation… I will try this configuration and will update about the resaults.

I’m using Taranis transmitter with SBUS transmitter, so I have CH8.

Regarding RSC mode 3, I can’t find this mode (only modes 0-2), please advise.

Thank you very much for your help.


Hi Rotem,
Mode 3 is a non governing function. It provides a 3 point curve for throttle output. The points are set with the H_RSC_POWER_HIGH, H_RSC_POWER_LOW, and H_RSC_POWER_NEGC. They correspond to H_COL_MAX, H_COL_MID, H_COL_MIN respectively.

I suggest you use mode 2 if you have an ESC that has a governor capability.


I’m using SBUS Rx, do I need to configure the Tx CH8 to act as the Throttle(directed to pixhawk CH8) and Rx CH3 should be direct to pixhawk CH3 (asmotor interlock switch)?

Thank you

No do not follow that diagram. Unfortunately it is outdated and misleading. The receiver RC channels should be mapped to the same input channel number in the pixracer.


So this is the right connection?

Thank you

No. Your table is not correct. When I have a chance I will post a table with what it should look like.

So the thing to remember is that you are not using the heli setup mode of the transmitter. You will use an airplane setup in the transmitter. So when I refer to channel 3 of the transmitter as throttle, I am just referring to the joystick control that you use to control Collective. I think they typically refer to channel 5 on the transmitter as gear but we use it for flight mode. For the pixracer output, the number in parentheses is the number for the servo_function parameter. All of the other channels should be set to zero. Here is the table of inputs and outputs.

Sorry about the table appearance. Hopefully you can still read it.
The swash 1,2 and 3 refer to the swashplate servos which is typically CCPM but can be changed if your swashplate connections are different.
Lastly will you use the governing function of your ESC?

Hello Bill,

Thank you for the table,
It’s appears that I connected the Pixracer as you show on your table (don’t know why I thought else).

Did a first flight today at stabilized mode and it was OK…:grinning:

I have the following issues:

  1. I’m getting the following message: “EKF2 IMU switching to compass 0” (or 1).
  2. Switching to Loiter, the swashplate move to maximum position and not responding to stick commands (tail and motor are functioning)
  3. The Heli is unstable on yaw axis (looks like servo overshoot).

Thank you very much for the help.

Great! Glad to hear that.

What external GPS/Compass are you using? Many times with electric helis, users disable the internal compass because it is affected by the motor. So only the external compass is enabled. But check your compass reading with a real compass to make sure it is reading heading correctly.

When you say the swashplate moves to maximum position, you mean it gives full collective. So this could be due to the throttle stick position. First in stabilize mode make sure that the aircraft hovers with your throttle stick near center. Then go to althold mode and takeoff and land in that mode. this helps ensure the autopilot is doing a good job controlling the vertical axis. Then move to loiter.

you may need to do some tuning of your PID parameters in the yaw axis. If it is overshooting, I think you’ll want to increase the D gain in 0.001 increments. If the aircraft starts to oscillate then reduce the D gain.

Hopefully this helps.