Servers by jDrones

3.5-rc8 Heli PreArm: Motor Interlock Enabled, PixHawk ( Solved)


(Sunit Pal) #1

I was flying my heli successfully using 3.4.6. Then I upgraded it to 3.5-rc8. Now I get the message “PreArm: Motor Interlock Enabled”. I am unable to find out the reason for this. This happens only when the RSC_MODE is set to 2. When I set RSC_MODE to 1, then there is no error. Is anybody else having this issue? I searched this forum but no one seems to have reported this issue. Some one reported a similar issue ( 3.5.0-RC2 On Heli with Pixracer- Can't Clear Motor Interlock (Solved)) but that seems to be dues to missing CH8 in the transmitter.


(Bill Geyer) #2

I have not loaded 3.5.0 yet. So I’m not familiar enough to say this is or isn’t an issue with the software but I would recommend posting this on the Copter 3.5 thread. Only because @rmackay9 will see it and they are pretty close to releasing 3.5.0. It would be good for him to see this and determine that it is or is not a problem before releasing 3.5.0.


(Pitt) #3

Try using throttle hold while arming then turn of throttle hold after it’s armed.

The controller won’t arm with “open” throttle.
I think it is above 5% from Ch8 min (~1100us) that’s considered as open throttle.


(Rob_Lefebvre) #4

So do you have Ch8 on a switch, RC is calibrated, and you have switch set low before arming?


(Sunit Pal) #5

Rob, yes I do have CH8 on switch and and is calibrated. I can see the values change in mission planner when I flip the switch. The same setup works fine if I load 3.4.6.


(Sunit Pal) #6

This is solved now. I looked at the code and it seemed that this problem can be solved by setting the trim to be lower in the radio for channel 8. I did that and it worked fine. I am able to arm and fly the heli. This is strange because I have other heli in which Pixhawk2 is installed and it works fine. The problem is only with the heli on which pixhawk 1 installed.