ZR10 2K QHD 30X Hybrid Zoom Gimbal Camera - SIYI's first industry gimbal camera and it won't be the last

@murcamil thanks for trying to help us out, i re checked all the firmware as you said but still we are facing same issue where video feed is missing and one thing to mention after sending pin on or 26 there is no connection (timeout) we tried the same setup with multiple mk15 but still the issue is same.
I would also request @SIYI and siyi support to please look into this issue its been past 1 week we are trying to debug the problem.

ZR10 Update Log


New Firmware

ZR10 Camera Firmware v0.2.8 svn544 svn636 2023-05-06

ZR10 Gimbal Firmware v0.2.7 svn6662 2023-05-05.bin

ZR10 Zoom Firmware v0.2.1 svn6675 2023-05-06.bin

SIYI PC Assistant En v1.3.4 svn6679 2023-05-09.exe



  1. New feature: Six way gimbal calibration can be done by customers now.

  2. Fixed: Conditions to alert temperature abnormal.

  3. Now ZR10 supports Mavlink analysis and GPS information forwarding.

  4. Change the calculation of floating point number of voltage to use integer operation to solve the error problem of floating point operation.

  5. Fixed: Temperature abnormal display.

  6. Now the gimbal does not center itself when it hits max / min mechanical angles.

  7. Fixed: Abnormal reading to S.Bus data.

  8. Fixed: When the gimbal is headed down by command, ZR10 will record the current flight path and do not drift from the path when the drone is moving.

  9. Optimization to unexpected roll angle tilt issue


  1. New feature: ZR10 pictures can acquire network time now.

  2. New feature: ZR10 pictures come with GPS information now.

  3. Fixed: Upside down mode is not activated when the app is not using SIYI video protocol.


  1. Optimization to auto focus.

  2. Fixed: Temperature control is off when the temperature is not changing.

  3. Remove the previous temperature control commands and boot loader determination.


1 Like

Hi Frank,
Can you please detail this:

I did not find anything in the manual or in the Ardu driver.
I updated to the latest and I saw that images have a GPS position but that is just Lat = 0 and Long = 0 since there is no MavLink connection.

Has anyone experience the ZR10 repeatedly writing images where some part of it is missing, like this one:

I tried with 3 different cards, and different formats, but I had the same outcome. The camera, gimbal, zoom have the latest fw.

The GPS and time information are supposed to be saved in the EXIF file

Please format your SD card’s minimum storage unit as 64 KB

We have uploaded the video of issue we are facing with two of ZR10 where we are missing video feed or connection issue. @SIYI please go through video for more clarification on the problem and also we are trying to connect with @siyi support team from past 2 weeks but we are not receiving any assistant through mail. We have uploaded latest firmware (15-5-2023).

  1. What is the app version?
  2. Are all firmware the latest? (a screenshot from SIYI FPV app - Gimbal Camera)
  3. Have you checked the Ethernet swtich in Android settings?
  1. We have checked the ethernet switch in the android system.

  2. the app version is V2.5.12.531.29a2942

  3. the gimbal version is 0.2.8 and camera version v0.2.8

Can you please detail more the GPS and time information? I am guessing the camera is somehow taking this info from the receiver but I would like to know more because I am using a Herelink and it does not work for me.

1 Like

@SIYI Hi Frank
As others said before thanks a lot for the well documented products and nice support

I have a problem with connecting the zr10 camera (all FW are the latest except the camera/sd FW) directly to my laptop.
I’ve tried configuring the ethernet cable available for the hm30 and using zr10 camera gh connector to be able to connect the camera directly to my laptop’s ethernet port but the wired connection is not stablished and it shows “connecting…” on the network setting on my ubuntu 18. Also pinging the camera does not work. (By the way, everything works fine with the camera through the hm30)
The pinout is exactly like the camera to the hm30 air unit being [null, null, rx-,rx+,tx-,tx+, null to end]
I even tried swapping rx pairs with tx pairs respectively for possible crossing ethernet connection but no luck on that too.

My goal is to finally be able to connect the zr10 to rpi and hm30 air unit through ethernet and a switch/splitter to be able to perform on-board processing alongside with off-board broadcasting.

Any other information on the problem is welcome to be given

Thanks in advance

Gimbal UART must be communicating with the flight controller, because the GPS information is from the flight controller

There is already an Ethernet to RJ45 cable coming with the ZR10 package


I read in previous replies someone asking about changing the netmask from the default
Is it possible to change the netmask now? I need to set the netmask to

Any replies welcome.

Thanks in advance.

I have that connected and still the images do not have the autopilot position information.
How could I debug this? I am using the latest ArcuCopter. The settings I have are as in the wiki.

Yes you’re right
I totally forgot about that cable.
Now I am using this cable and still the ethernet connection is unidentified.
My knowledge in networking is not so good, so i was wondering if I need to change the ip or gateway of either my camera or pc?! But i don’t know what should i change them to!

I would appreciate any help

For other people with the same problem in the future, the answer is that you should set the ip of your pc same as the gateway of the camera and the gateway of the pc equal to the ip of the camera

@SIYI Hi Frank, I have send an email to your support team this week with a ZR10 error after the latest FW upgrade. I got a strange sound. I’ve created a video for this. Could you ask them to have a look?
I’ve checked version and re-flashed.

Just updated my FW on the ZR10. What could this sound mean?

  • If I touch/move the gimbal, sound goes away but comes back frequently.
  • If I move the joystick Up and Down, it goes away.
  • If I move the joystick Left and Right it does not go away.