ZR10 2K QHD 30X Hybrid Zoom Gimbal Camera - SIYI's first industry gimbal camera and it won't be the last

Hello Frank.

I think you didn’t understand me. We have a problem with the QGC app in video broadcasting. Yes, I was testing your modified QGC, but it didn’t help me, and we want to build our Android app. Can you help me with the source code for building my QGC app?

You need ETH to HDMI converter

May I know some detail about this problem, please? Better checking a video.

I tried searching. All available convertors are hdmi to eth not other way

ZR10 Update Log
22-9-14

New Firmware
ZR10 Camera Firmware v0.2.5 svn307 svn329 2022-09-14

ZR10 Gimbal Firmware v0.1.9 svn6097 2022-09-14.bin

Updates

  1. New feature: Upside down mode is available for the gimbal
  2. New feature: FPV mode is available for the gimbal along with improvement to the lock mode and the following mode (for S.Bus control, you need a 3-stage switch for the three gimbal modes, for example: -100 = Lock Mode, 0 = Following Mode, 100 = FPV Mode)
  3. Improvement: Gimbal control algorithm, increasing the imaging stability in high zoom level and the compatibility to different frames

@rvjenya

1 Like

Nice. But when will it support the new mavlink gimbal commands from ArduCopter 4.3.x?

I’ve started writing an ArduPilot driver for the Siyi ZR10 based on the SDK information kindly provided by @SIYI above.

If any one is interested the code is here and if anyone could help me test it I’m very happy to provide a test binary if you can tell me which autopilot hardware you’re using and which vehicle (e.g. “CubeOrange” for “Copter” or whatever).

This is still very much a work in progress but I would like to at least confirm that I have the basic communication working.

The way to test would be to:

  1. Compile this branch and load onto your autopilot (or tell me which autopilot and vehicle you are using and I will compile a firmware for you)
  2. Connect the Siyi gimbal’s RX, TX, GND to one of the autopilot’s serial ports
  3. Set SERIALx_PROTOCOL = 8 (SToRM32)
  4. Set SERIALx_BAUD = 115
  5. Set MNT1_TYPE = 8 (Siyi)
  6. Reboot the autopilot and power on the gimbal
  7. Connect with a ground station and check the messages tab (if using Mission Planner go to the Data screen and clikc on the “Messages” tab in the middle / left side of the window)

If all goes well you may see some debug output like this:

Siyi Board ver:A.B.C
Siyi Firm ver: D.E.F
Siyi Zoom ver: G.H.I
Siyi: Angle R:xx P:yy Y:zz
Siyi: Rate R:xx P:yy Y:zz
Siyi: bytes:XX succ:YY err:ZZ

If things don’t go well you might not see anything except a “Mount Unhealthy” message occasionally.

2 Likes

Thank you very much for your help, Randy.

Our team want to join the tests to speed up with development.

The flight controller we will use for testing is Holybro Durandal and we will test it with quadcopter.

Please feel free to me know if you need any more information.

And we are encouraging more ZR10 users to join the tests! Everybody hands up!
@amilcarlucas @WTech @rvjenya @Tsuyoshi

1 Like

@SIYI,

Great, here is a binary for Copter-4.3.0-DEV (aka “master”) for a Durandal autopilot with the new Siyi gimbal drive added.

By the way, for the wiki we will need a wiring diagram which is probably something like this. Any input on the colour of the wires for each of the pins or the order is greatly appreciated. So for example if someone does successfully wire up the gimbal’s UART to an autopilot’s UART could you send me a picture?

Randy, I’m able to test the ZR10 on a Cube Black and Orange. They will be on my test bench so can load any FW. I’m especially intetested to have it in Trad. Heli.

Bart

Me using Matek 743 V3

I have a new bug about zoom when I direct the camera to the ground.
My copter is stable in Loiter mode (no-move aircraft), but I’ve got a slow-moving zoom camera image.
I tried all gimbal modes, but I’ve gotten this result.

I use CubeOrange, Copter 4.2.3
Please build me firmware for ZR10 I’ll try to test it.

1 Like

Thanks for your feedback.
Can we request a video for this potential bug, please?

This new code is only available in the 4.3.0-dev version. You will need to update.

Has anyone had success? I found that the RX and TX of this picture are correct.

2 Likes

Hi @cuav_le,

There were a couple of bugs in the parser that I have now fixed. I’ve also borrowed a Siyi gimbal from a friend (just for today) so I’m looking into what other issues exist. So far I’m actually not getting any bytes from the gimbal… I suspect I have the wrong firmware on the gimbal or I need to use some setup application to configure the gimbal to be able to communicate on the UART.

May I know what gimbal camera firmware you are using, please?

We suggest that you can update the gimbal firmware to the latest version.
https://drive.google.com/drive/folders/1F78-MDyWRp-SX49dYeDlCCW9kxQp8j8T?usp=sharing

1 Like

Can you send a set of ZR10s for Randy?