Yuri's Mower Updates

We still had that problem even when we just were working with 2 bare boards (no radio)

That’s because GPS_SAVE_CFG is disabled, so the boards revert to default whenever power is removed.

You have overridden the config on the moving base at least once, so that’s why it’s working without issue.

Another way of accomplishing the same thing is this:

Set GPS_AUTO_CONFIG=1 and reboot. Once the boards are powered and working, Connect them to u-Center while they are still attached to the autopilot (the boards have onboard power management to avoid issues between multiple power sources). Go to the CFG page and “Save current configuration”/Send. You can set the GPS1 baud to 115200 at the same time (and remember to disable GPS_AUTO_CONFIG before power cycling).

I have to be away for 20 minutes or so and then I will do exactly as you request above

FIrst, set GPS_AUTO_CONFIG=1 and reboot. Then set GPS_SAVE_CFG=1 and wait for a message that says that the config has been saved to both boards. Set both of those parameters back to 0 and then set the moving base’s UART2 baud back to 115200 in u-Center.

I think you are onto something there for sure.

1 Like

Well Yuri I think we have it working pretty good now. I did the steps you mentioned above except I haven’t put it back on U-Center and it is still working with RTK Fixed on both GPS units and the radio never quit working. That was puzzling to me and I don’t know if the configuration process didn’t change the baud rate because I had an active radio connected to the UART or whether the UART2 did some sort of auto baud change. Either way it seems like it is worth knowing, because I did set GPS_AUTO_CONFIG=1 and I rebooted. I expected that radio to go silent. Both GPS_AUTO_CONFIG and GPS_SAVE_CFG are both set to 0 and I have rebooted several times and it has been coming back up working with RTK Fixed on both GPS boards.
I’ll get back on U-Center using the method you described and save the current configuration of each board and look at that baud rate on UART2 of the moving base.

I owe you Yuri and I couldn’t have gotten here without you.


I think you’re there. Unless you want to re-examine the crossover connection, there’s not much more to do!

I’ll leave it the way it is for now. I did just plug each board into U-Center to save the configuration of each board while Mission Planner was running and then I looked at the baud rate of UART2 on the moving base and it was still set at 115,200. For some reason AUTO_CONFIG didn’t change it. One of life’s mysteries. The radio was turned on at the time and it stayed on.

Thanks again Yuri you are a tremendous help to everyone.

Here is a link to some pictures I posted over on the other thread.


Glad you got it working. I went through all of these frustrations amid the start of the pandemic when the codebase for moving baseline was barely functional - wires and antennas strewn all over my porch! Learned a lot and want to help alleviate the frustration that can happen when things go awry.


I have another issue on Rover 4.1, I use 2 antenna RTK GPS for yaw. It works as well.
But when I put my rover in a very weak GPS single location for over 3 hours or longer, then move the rover back to strong GPS single location, it shows RTK fixed, but yaw is turning 360 continued. The rover can’t run at Auto mode correctly. I have to reboot the rover.

How I can fix it in Rover 4.1.

First, update to the latest firmware.

@Yuri_Rage @SJohnson Hello, I have read the whole post. thanks for so much effort. I have gone through almost exactly the same thing you describe and configured all the options to the point of feeling dizzy.
I feel better not to be the only one with this problem. =)
I have also solved it in a similar way, exchanging the configuration software between U-center and ardupilot and finally it has been working with both gps at 460.
first using communication through the cube and then directly between both GPS (Ardusimple heading kit).
In my case, I’m using arducopter 4.2.2 instead of ardurover and what I can’t get rid of is the “unhealthy GPS” message. Seems lihe the severity of this issue in this particular case is not documented yet, so i dont feel confortable try to fly in that condition.
In their messages they hardly touch this point.
Has it appeared to you?
Cheers !

The best way to avoid these kinds of messages is to revert everything to default in u-Center and then let the autopilot do the configuration for you. Otherwise, any mis-step in u-Center can result in unexpected data rates (or packet sizes) that cause communication hiccups.

@Robotic @Yuri_Rage @ktrussell
I just wanted to report that I did download (and learned to use) the DIGI XTCU X-Bee radio Configuration and Test Utility software. It also required a USB adapter to interface the radio to my laptop, which was only $9 from The Robot Shop store online. It was very easy to re configure the baud rate for the LR Ardusimple X-Bee radio itself. The website to get the software is XCTU
I was able to set the baud rate of the serial output of the radio itself to 460800.

XCTU pic
The RF data rate was left at 110 kbps. It was easy to reconfigure the radio and the best part of the experience is that the radio works with the Ardupilot software while GPS_AUTO_CONFIG=1 and the whole dual GPS-YAW setup comes up running now with the radio receiving the RTCM3 correction signal from the base station and transferring it to the moving base.
I also need to mention that right after I put the radio back on the moving base before and before I did the auto configure, I had plugged in U-Center to the RTK2B GPS board and set the baud rate for UART 2 back to 460800. I was just a little reluctant to auto configure until I understood things. Anyway, it came up running receiving correction signal but it had the “unhealthy GPS” message. In my case I thought maybe the GPS boards were swapped, so then I ran the auto configuration in Ardupilot on the boards and everything straightened out with the message gone and everything working.

1 Like

Yuri, Im already rebuild my setup and flash both GPS for do a clean setup.
Steve, thats a grat tool. what GPS_DRV_OPTIONS are you using ?

I am using GPS_DRV_Options=0 and it should give an rtk Fixed indication on GPS2 if all is well. It sends the RTCMv2 data generated by the GPS1 (Moving base) through the flight controller over to GPS2 (Rover). This method eliminates the need for the connecting wire between the boards. @Yuri_Rage is the one who really knows this stuff. In my case I get the RTCM3 corrections injected into my Moving base from the X-Bee radio link to the base station. If you can do it, I would strongly support having the boards configured by Ardupilot it eliminates problems.


I couldn’t have said it better than @SJohnson’s recommendations.

1 Like

@Yuri_Rage, @ktrussell, @jason_miller
Well I have been working hard to get my mower tuned and I have made great strides up until I broke it. It was actually following way points pretty nicely and I was very impressed with how well it was doing. Learning how to use Mission Planner slowed me down a little, but I have been very impressed with the utility it offers and the ability to interface it to Excel to manipulate files.
I have been having trouble with my GPS for Yaw system lately, it has not been reliable and it seemed to be getting worse each day until today. Then it just stopped working and nothing I do seems to help.
Screen pic 092922
Overall observations:
Mavlink Inspector indicates GPS for yaw is not working (Yaw reading 65535)
The GPS2 (moving base board) is very hot down by the rail setup where the radio is plugged in. The area I have circled on the picture id hot enough to burn your finger, and it is just as hot with the radio unplugged.
I plugged the ArduSimple RTK2B board into U-Center and the GPS part of the board seems to be just fine (it locked onto 30 satellites). The board was still just as hot when it was connected only to my computer with the ArduSimple radio removed. I also tested the other GPS1 board on U-Center and it tested fine and it was about room temperature to the touch all over.

I have rebooted the flight controller many times to try and reconfigure the GPS boards

I put both GPS boards on U-Center and revered them back to the default configuration and then tried to boot-up with Ardupilot, but it made no difference.

All RTK indications for GPS1 and GPS2 have gone away.

Maybe, I have burned out a power supply on that board that powers the radio. Anyway, the radio still works, I tested it separately on the Digi XCTU software, but I don’t get an indication of RTK on the GPS unit.

I am kind of stuck at this point and I am not sure how to proceed.

Your power distribution seems suspect at this point. Do you have a good multimeter that you can use to probe input and output voltages?

1 Like

Thanks Yuri, I’ll get out my meter and check it out tomorrow. I am kind of thinking it probably means I need a new GPS board. Maybe that radio plugged into the board stressed it out. When I put it all back together. I will consider mounting the radio on a serial adapter board and powering it off of an external power source (not from the board).

Steve, That’s a bummer on the board giving trouble.

Interestingly, I had a very similar problem with an Ardusimple RTK2Bb board about 2 years ago. This is part of the email I sent to Ardusimple: "The board still seems to operate in that I can connect USB to it and see data in u-center, but the TX1 output is not working and I noticed that the 6-pin IC near it with label IBSD (or similar) is super hot. You cannot hold your finger on it. "

That may not be the same chip you have circled, but it could be the same issue just on a different port. Ardusimple support was extremely helpful. They offered to repair it, even if it was out of warranty. But I chose instead to order the part and try to repair myself rather than shipping back to Spain. Ardusimple provided the part number to me: SN74LVC1G3157DBVR. I do not know if that is the same part you need or not.

Another tidbit, Ardusimple told me this:
“The failures of this component we have seen are 2:
o Connecting it something above 6V to one of its pins,
o External short when soldering arduino headers.”

Sadly, the replaced part did not fix the board. I still have it though and it can still be used as long as I do not need the TX1 port.

The point of my story, really, is that Ardusimple has excellent customer support from what I can tell. You should reach out to them.


Kenny, it is interesting that you had pretty much the exact same problem. When the board quit working it did seem very much like TX1 quit communicating. It would not talk to the flight controller. Anyway, I did reach out to Ardusimple in Spain and they do want me to send the board back to them for evaluation, which I will do. I have also pulled the SimpleRTK2B board out of my base station so I can use it on the mower. I have a spare SimpleRTK2blite board that I am working on putting back in the base station. I am just mounting it on an ArduSimple mount anything adapter board to hold it and supply power. The small ArduSimple X-Bee radio module is then plugged into the header on top of the lite board. The base station is working, but as of right now it is not broadcasting any RTCM3 signal and I am still working on that. I have noticed that that little RTK2Blite board will complete a “Survey-in” on the antenna location very fast. When it had the full size board in it, it was slower.
I have put the board I took out of the base station in the mower and I have it working now, minus the RTK signal getting to the moving base board from the base station. I am sure I will get the RTK signal back when I get through going over everything.
My biggest concern is the fact that the whole GPS-Yaw system seems so sensitive and it seems to give the “Unhealthy GPS” signal often, quit working giving the huge variance from the compass reading, and flip around the GPS status from fixed to dgps. Sometimes it works fine and sometimes it is just unreliable. I am just using the original ArduSimple black “puck” antennas with the really long cables coiled up. Do I need to shorten the cables and/or get better antennas? I realize the sky conditions influence this but sometimes I am locked on to 30 satellites and it will still get flakey, and ometimes it is fine for hours.
I also intend to figure out how to get the RTCMv2 data connected to GPS1 (Rover) by using the external wire from the Uart2 on the moving base connected to the Uart2 on the rover GPS. It should be simple, “Its one wire”, but Yuri and I worked on this before until I just gave up and set GPS_DRV_Option=0. I really want to get this working now since I am setting it back up with the replacement GPS board. If I can get the signal going over the wire it might free up resources and help with the reliability problem. Maybe now with a different board in there it will work. I have also connected the 3v3_OUT pin to the IOREF pin on both GPS boards as requested by Yuri.

Below, is a picture of the RTK2BLite base station. The radio doesn’t seem to be working at present but I am working on it. I need to check my baud rates an other setup parameters. If I have that radio plugged in backwards I am sure you will net me know. I will check the pin configurations on both boards tomorrow. I used the information on orientation from the ArduSimple website, but I have learned to be skeptical.