Servers by jDrones

Yaw rotate on waypoint in mission - how to achieve?

Dear All,
Is there any possibility to rotate drone (for example turn around 5 times) in Yaw axis on current waypoint programmed on mission planner? I want to achieve the same thing like hovering my drone controlled by remote controller in LOITER mode and move left stick (Mode 2) to the maximum left(or right).
Thanks, happy flying!

To rotate the drone around you can use LOITER_TURNS and set the CIRCLE_RADIUS in your params list to 0 so it rotates around itself and not makes the waypoint like a point of interest! If you want to look at a point while flying then use DO_SET_ROI!

1 Like

Thank You Yaros1 for the answer!
I’ve tried this method, the drone was rotating by 90° 4 times to make full circle, but it stopped every rotate 90°. I want to turn around full 360° with maximum speed of yaw rotating, and the dream will be if it will rotate 10 times for example.

Read the docs! This is what it says:

Setting the CIRCLE_RADIUS to zero will cause the copter to simply stay in place and slowly rotate (useful for panorama shots).

The speed of the vehicle (in deg/second) can be modified by changing the CIRCLE_RATE parameter. A positive value means rotate clockwise, a negative means counter clockwise. The vehicle may not achieve the desired rate if this requires the acceleration towards the center of the circle to surpass the maximum acceleration held in the WPNAV_ACCEL parameter (units are cm/s/s).

And this is the command you want and every parameter:

Does this help?

1 Like

Dear,
I’ve read the docs… it still doesnt rotate like docs says, I will send You movie how the drone rotating ASAP.

1 Like

How fast are you trying to Yaw it with the CIRCLE_RATE parameter? It is faster than ATC_SLEW_YAW?

1 Like

Circle_RATE is set to 90, didnt knew about dependency with another parametere (ATC_SLEW_YAW) I will check this parameter too and come back to You. Will record short movies with changing of parameters. Thank You guys so far for Your help!

1 Like

That won’t work. You can try to set Atc_slew_yaw to 9000 and try that rate but it might not do it.

1 Like

Hi, setting ATC_SLEW_RAW to 9000 solved my idea, changed to 18000 solved twice :smiley: thanks!

1 Like
Servers by jDrones