Servers by jDrones

Yaw_rate ignored in guided mode

Hi,
I’m flying in guided mode with an optical flow (CX-OF pmw3901) and lidar.
My companion computer sends set_position_target_local_ned
with velocity and yaw rate fields.
I flew several times very successfully and then for some reason the controller started to ignore the yaw rate field, while the velocity was as required.
Any idea why this might happen?
Unfortunately, the log (GUID) doesn’t show the yaw rate field, it only shows position and velocity. Is there a way to log the commanded yaw rate?

Thanks!

Try updating to Copter 4.0.3

Hmm… why?
So that I can get POSITION_TARGET_LOCAL_NED messages? or was there some fix relating to the yaw_rate field of SET_POSITION_TARGET_LOCAL_NED?

Here is an example - once I switch to guided mode, the desired yaw rate (blue) and actual yaw rate (green) don’t match anymore. The red line is RC4/100 for display purposes.

From your questions I assume you tested that that feature is not implemented in 4.0.3?

Mystery solved- the rc4 deadzone was set to 2!
The rc center was at 1497- out of the deadzone. So the rc took precedence over the guided commands. I increased the DZ and everything worked.
Only question now is why can you yaw with the remote while in guided, but not do anything else?

Servers by jDrones