Servers by jDrones

Yaw not responding (toilet bowl)

hello
i have pixhawk 2 cube and herelink on the 650 tarot frame 400kv xing motor 15’’ prob and hobbywing xrotor 40a esc
and i used 6 cell battery
i did the esc,compass and radio calibration also i tuned the motors as it’s in here Tuning Process Instructions
after i completed all parameters i tested it and went crazy totally unstable and fast and crashed …
i had this problem after i changed the motors (old motor: sunnysky 600 kv it was stable )

this is my parameters and i used arducopter 3.6.11 firmware

bad flight.param (14.3 KB)

https://drive.google.com/open?id=1mtnty-WiPEHorId299Vk_AvLk8b372Ka FLIGHT LOG

note: i used arducopter 4.0.1 and i did not found the auxiliary channels in the flight mood section so i flashed 3.6.11 again

Send your log from the flight controller.

1 Like

The main thing I noticed was you have your arming checks turned off.

You will not get much sympathy here in that case.
The arming checks are there for a very good reason.
Try turning arming checks back on and work your way through the error messages and fix them.

Toilet bowl - bad compass calibration
Did you calibrate the compass?
Were you in Stabilise mode?

1 Like

@Eosbandi these are my logs https://drive.google.com/open?id=1mtnty-WiPEHorId299Vk_AvLk8b372Ka

@mboland
thanks for your reply
i get no error messages and you can check my log log file
i did the compass calibration more than ten times and also changed the FC and it’s the same problem again!

LINK for video it’s not responding for yaw and it’s fast

Was it flying perfectly with the 600kv motors ?
I don’t think it is toilet bowling!
Are all the motor mounts level. ie. the motors are perfectly upright ? I suspect the anticlockwise motors.

1 Like

yes it was flying perfectly …
but after i changed the motors toilet bowling started and also it became unstable
is there a way that the motors are not compatible with the esc’s
and yes the motors mounts level and it’s perfectly upright … i checked all the hardware

ls this your motor specification,


I am not an expert, but I think a 40A ESC is OK.
Someone more experienced will have to comment.

1 Like

yes that’s my motor…
i hope someone help out of this problem

You’re still running with arming checks turned off.
You need to turn on your arming checks and work through the errors until there are none.
Until then, why would you expect it not to crash.
The arming checks are there for a very good reason.

Looking at the motor outputs it seems you might have the motor order or motor direction or props in the wrong order.

1 Like

Hello mike @mboland thanks a lot for your help
today i upgraded the firmware to the latest 4.0.1 and parameters still the same and i did turn on my arming check and also i made the 3rd compass is primary and disabled the internal compass
first i changed my frame and put the Cube on another drone with 920kv motors and also test it with another radio (AT9) … it fly stable and there is no problems
so i remounted the Cube on my new drone (but with the AT9 radio not the Herelink) again to test it and it also have the same problem!!! no yaw respond and very fast and unstable response from the motors
Here is my logs and test video so you get to see what is happening .

https://drive.google.com/open?id=1R3OAg5q79rc0rDB5BLnc27tgMZJy1ERQ

many thanks in advance

Fix these, they are both very wrong:
BATT_VOLT_MULT 456.9505920410156
BATT_AMP_PERVLT 5.248218059539795
They may be driving the motor mixer crazy and making the PIDs have exaggerated effects.
Calibrate the voltage sensor at the lowest voltage you’re likely to see, not the highest.

Definitely do the Compass-Motor calibration, follow the docs closely or it’s very dangerous.

Did you check motor order and prop rotation in the mission planner motor test section?
A is front right, B is back right, C is back left, D is front left (order goes clockwise).
Check prop rotation against the diagram in the docs:
https://ardupilot.org/copter/docs/connect-escs-and-motors.html#connect-escs-and-motors

If the problem persists after that balance you props and recheck vibrations - there’s some vibes in that most recent log, and a bit of clipping but that may be due to a hard landing or similar.

You should set these:
BATT_FS_LOW_ACT 2
BATT_FS_CRT_ACT 1
FS_THR_ENABLE 2 (and test before flight)

1 Like

And update to Copter-4.0.2, it’s out now.

1 Like

And probably drop this one:
ATC_RAT_YAW_FLTT 20
down to:
ATC_RAT_YAW_FLTT 12

1 Like

This indicates that you have a basic problem with your frame/motors/esc combo.
Relax, sit back and start over.
0. Start with a clean slate. Install ardurover on the cube then install back Copter. This will clear all settings. Set up again but do not touch any PIDs.

  1. check motor directions
  2. check prop directions
  3. check motor order
  4. check ESC calibrations
  5. check motor desync (run a a single motor with prop on it and rapidly change throttle with a directly connected radio…
  6. set up correct battery voltage measurement
  7. Do recheck the tuning process setup steps.
  8. do an in hand testing (with some protective gear and with a helping friend). Switch to stab, hold it firmly above your head and give some throttle. Check resistance against movement (roll, yaw, pitch) and check response for controls (roll, yaw, pitch).
  9. try fly it in stab.
2 Likes

thanks a lot for your helping @xfacta @Eosbandi
i think the frame is too weak and when i give it yaw it twisted and cause an error so i’ll change back to 600 kv motors
i’ll do your steps and test the result
but i just didn’t get step NO 5 and how should i do it ?

The problem could be because you are flying indoors.
I watched the video and heard it crash against a metal wall

I have had customers not being able to launch a craft because it was too close to a Man hole cover or it was on concrete with lots of metal rebar.

I know its cold, but I would try it outdoors.
Snow is also a lot softer to land in if you have a problem
This way you know the GPS and compass are not getting odd readings.

1 Like

thanks Jeff recently i tested it in an open area and it have the same behavior
so as i mentioned in the last comment i think it’s the frame or the motors just not compatible with ESC now i changed back to my SunnySky 600kv motor because it was working so good in it
i want a frame that could handling at least 400kv xing motor and a 4 kg payload what should i use?

Servers by jDrones