Yaapu telemetry on openTX ELRS frsky Horus X10

I’m trying to get Yaapu telemetry to work on my Horus X10. I have:

Yaapu telem 1.8.1
ELRS 1.0.1 on my betaFPV 900 MHz rx
ArduCopter V4.1.0-rc2

but nothing is working it seems. (I apologize if this is in the wrong section, I’m really new to the forums if it needs to be moved, please do)

I have referenced this thread and set everything accordingly but I still get no telemetry data:

Passthrough telemetry over CRSF (crossfire)

These are the params I have set recent_param.param (16.5 KB)

I’ve heard that you need to have a GitPull version of the ELRS via this post however I can’t find the version its referencing:

Passthrough telemetry over CRSF (crossfire) - #897 by yaapu

I’m not sure what I’m doing wrong and I don’t know what to do here if someone could link me to the versions of stuff I need to install and/or a guide on how to do all this it would be very greatly appreciated.

Hi, you need Yaapu 1.9.5 and ELRS 2.x. Don’t forget to enable crossfire support in the widget config menu

I dont see an ELRS 2.x release unless you’re talking about the 1.2.0 release?

ill upgrade yaapu after lunch here in a bit though

Thank you lots Captn’ Yaapu

ELRS 2.x is current ELRS master branch

check here

I can’t seem to get my controller to bind now, perhaps I messed up the update to the master branch but my RX goes into wifi for a split second and then begins flashing erratically…

like a combination between the wifi flashing and the searching for TX flashing

Hi,. sorry can’t help with ELRS specific issues :frowning:

I got help elsewhere and managed to resolve the issue, thank you for your help so far, I really appreciate it.

I have yaapu running however it does not display/update my sensors correctly, if I go into my telemetry page in my Horus I can see all the data being updated and displayed but not in the yaapu widget

1 Like

Is it possible to use this Yappu telemetry on my Radiomaster Zorro running edgetx? Thanks so much.

Hi, yes it should work. Use the X7 variant


Hi Yaapu, well i managed to get the script displaying on my zorro but with no yaapu telemetry. ( I DO get ardu telemetry in my other telemetry screens on my radio, such as rssi, gps, flight mode etc. )

No converter cable is required for elrs, right?

To confirm, i have yaapu 1.9.6 dev and elrs master, as per your instructions.
Edge tx 2.6.0 . In your scripts config menu i have selected “enable crsf” . Arduplane 4.1.7 .
Using matek r24d receiver , matek f405wing , on the dma uart ( uart1 ) .

rc_options=800 (arming check throttle zero,suppress crsf message for elrs, use passthru for crsf telemetry)
rc_protocol=512 (crsf)
serial1_baud =57
serial_protocol=29 (crossfire. i also tried =23 which is rcin, still same result )

Any ideas?
Thanks so much.

In expresslrs config the telemetry ratio was set too low.



Need some tiny help with the yappu config. Everything working ok, however how to achieve the correct battery percentage/left/consumed when battery is less then 100% charge.
What I mean: when fully charged battery connect to arduplane/Matek flight controller, arduplane/yappu takes the battery status full, which is correct. But, if you fly for 30 min, let say 40% consumed and you disconnect the batter and connects again, ardu/yappu takes the voltage as a startup/full battery.

I did try to play around with override settings but no effect.

How to achieve the correct batter level of the battery if it’s less then 100% ?

I have 6s setup

Hello Alex,

thank you for your nice work!

Yaapu telemetry is working fine on my ELRS transmitter. I noticed that it needs to be above around 1500bps to show the all the data on the screen. mine is 333hz full 16ch rate/2 with telem ratio above 1:16 to show all the data. or 100hz full with telem ratio above 1:8. is it normal for the now or it has some other setting that I can lower the ratio with full data showing on the screen.

yes, there’s a limit, telemetry rate should be >= 25Hz, so 50Hz 1:2, 100Hz:4 and so on, 100Hz 1:8 is too low.
No settings can lower this requirement, a good user experience at this low rate has already been a challenge :slight_smile:

1 Like

HI, I wonder if anyone could help with my problem at all briefly;

I am trying but failing to get telemetry data to display on the Yaapu widget I have tried two different setups but with the same result.
Set up one, A Frsky X20s currently on ethos 1.4.11 Eu transmitter and a TDR6 receiver on HW 1.1.0 FW 1.0.9 with a invert cable from Amazon plugged into Telem 2 Pixhawk 2.4.8 with Ardupilot 4.4.0
Set up two A Frrsky X12s on 2.3.10 Open tx and a XR8 again using a different Amazon supplied invert cable plugging into same Pixhawk 2.4.8. running Ardupilot 4.4.0

The same problem is occurring on both setups leaving me to think Im doing something wrong in the Ardupilot set up. I can have the Serial_2 Protocol set to 10 and there is nothing showing on the widget display and no extra sensors discovered. Once I change to Protocol 4 Frsky smart port I can discover about 19 sensors, but swapping back and rebooting to protocol 10 these sensors are not live anymore.
I have tried nearly all combinations of the options on port 2 along with protocol 10 but alas no passthrough data appears to be coming from the pixhawk. I have also looked at the Yaapu debug screen but every line appears to have 0 data being received?
I would love to have this app working to be able to get rid of the need for a miniOSD/seperate screen etc to discover arming issues and the like, I realise that the Yaapu widget doesn’t use sensors but the passthrough data which isn’t discoverable in the normal telemetry way however Im stumped in how to check for this function any further. Can anyone suggest a fix?

finishing up after 1 1/2 days, that must be a record!
Kakute F7 HDV which I am converting to ELRS to evaluate a receiver.
I believe I had 2 main problems: 1) it appears the official releases, at least for this AP, maybe others, do NOT support ELRS /CRSF(passthru telemetry, that is…I had no trouble getting radio channels to come in), in spite of the instructions in Ardupilot doc and elsewhere. I downloaded a custom build, herein I believe, and it got the arducopter telemetry to show up on the telemetry setup screen (radio; you may have to use Discover new). Then found (with hints herein) that the Dev versions which can be manually downloaded and installed, support ELRS/CRSF. Well, I can kind of guess why that is, but where is the doc?
Oh, I also used a multimeter scope, and could see the telemetry coming out on serial 3 Tx once I loaded a non-release version.
2) once I had telemetry in the radio, I finally re-installed the Yappu widget under transmitter screen setup (after going over, and over things for hours), and when asked to select a version (after selecting Yappu), I selected the default instead of what resolution I thought my TX16s is… I saw that mentioned herein, but did not get where to do that default thing. (My screen worked, but the diagnostic said NO TELEMETRY, when there are gobs of telemetry. The problem appears to have been a screen configuration selection problem of some sort.)

Now working well. And only a day and 1/2 of my life.

Let’s see: RC_Options: 8992; RC_Protocols: 512; Serial3_Options: 0; Serial3_Protocol: 23 (29 - Crossfire doesnt work!) ; Serial3_Baud : 115 (I believe this totally doesnt matter) (all in Mission Planner)

So, there you have it, simple enough! I may have forgotten something, but no matter, you will figure it out in a week or so… (I did enable CRSF in the Yappu Config which shows up under System tools. I wound up with an old Yappu menu still, under scripts, which I suspect is a remnant of the copy/paste and does nothing now. I may clean that up later.)

This information is disclosed freely, in the hope of saving human life…

I have no idea why Yaapu is broken after it was working fine.