Yaapu freezes on start up

I’m having some issues with Yappu on a plane using AP 4.3.5 with a Matek H743 V3 and Frsky R-XRS receiver. The receiver is on serial7 using the Rx pin for FPORT using protocol 23 and serial options 15.

This setup worked fine for some time but now when I connect my plane I get the first few Ardupilot messages displayed on my Radiometer TX16 and then the display freezes. I’ve tried different baud rates, serial options without luck. I also updated from Yappu 1.95 to 2.0x.

Any idea what else I can try to get the telemetry displaying again on my radio with Yappu?


I might have the same problem. But i never got it working in the first place. (Did not invest a lot of time yet)

If you can share your TX and ardupilot settings i can doublecheck it.

Does it still work with the older ardupilot firmware?

Thanks. What other info is needed than what’s posted? I tried ArduPilot V 4.2.3 and V 4.35.

The info message that Yappu stalls on is usually:

00:00 DBG RCInput decoding FPORT(3)

Sometimes I get one more message:

00:00 INF ArduPilot V4.3.5 (3bf6d7ac)

i am having the same problem as darrel on a matek f7 v1.5 board.
my fport is connected to com 6, protocol 23 options 7
i get mostly the same messages through as darrel, but have got partial messages and occasional gps error messages

More info.
tx will not reconnect telemetry if poweer is cycled
tx receives mavlink only on powerup, not on reboot.
blue light flashes for 3-4 seconds then turns solid then two lines of mavlink received on tx

More info.
set board boot for 10 seconds and the messages still come at 4-5 seconds from power on.
this plus hard boot make me think this is tx/rx issue

also mine stopped working after flashing new rx firmware and updating open tx and yappu

There’s a blog about Yappu here. It has 2099 entries. Is there anyway to display it with newest entry first? It will take a long time to scroll through that many entries.

I put the R-XRS in another plane that uses a Matek H743 V1 flight controller using the same settings and it worked fine. So there must be some difference between the H743 V1 and V3,

For this plane (with Matek H743 V3) I installed a Frsky X8R which outputs telemetry on a separate wire from the RC control and it worked fine as well.

Both planes now have Yappu working well with the RadioMaster TX16 but it remains a mystery as to why the original configuration was working one day and not the next.