Workaround to Arm KAKUTE H7 V2 Flight Contgroller


I’ve posted some questions before why the Kakute H7 V2 flight controller takes between 5-10min before you hear the motors play the arming tune. I found that after the FC has acquired GPS Lock for some reason, the motors will not play the Arming tune and you will not be able to ARM the motors even when Fence is not enabled. To make the motors play the arming tune, here’s what I am doing and its been consistent.

  1. Plug the main batteries

  2. Wait until GPS 3D fix lock is acquired.

  3. Plug in a USB back-up power.

  4. Un-plug the main batteries.

  5. Plug in the main batteries - This time the motors will play the arming tune.

If FENCE is not enabled, then you can already arm the motors and fly, otherwise you have to wait for GPS Home to be acquired.

Is this a Kakute FC issue or a program error? I suspected that the supply voltage of the Kakute is below the threshold. Measured it but its 4.6V. To eliminate the double, I installed a 5V BEC but this did not solve the problem. The Quad is uploaded with Copter 4.3.1-rc.

The quad has been flying very nice and I am enjoying it. But if the additional steps to make the motors arm can be elimnated, then I don’t have to carry a backup USB Power anymore.

Here’s a video of the workaround.



I have this FC and have been flying it fine for a while - no issues with arming. I suspect this might be down to your ESCs. What ESCs are they? Can you post your parameters?

Hi Andy,

Thanks for getting back to this. I tried to download the log only to find out that the FC is not recording any log at all. So I followed my workaround to arm the quad and hover it a bit but still there is no log that is being recorded. I will get back to you once I figure out how to fix the logging issue.

On the ARMING_CHECKS, Logging Available is set. LOG_DISARMED is also set to 1. This FC has been recording logs in the past. This morning when I launch Mission Planner, there was a message that a new version is available and I decided to install the new update. I woudln’t belive that this has cause the issue. We’ll keep on looking.

By the way, the ESC is Holybro Tekko32 F4 50A 4in1 ESC running on BLHeli.



Just post the parameter file.

In the BLHELI ESC settings turn OFF Low RPM Power Protect
It’s OK to set the Temperature Protection to 90 or 100, but that wont immediately affect flight

I have that ESC - works fine with my KakuteH7 v2. On the logging, these boards log to flash and it’s possible to corrupt the flash. Try erasing the chip (clear logs in MP or something like that) to get logging back. Post your params - I will be able to double-check if you do.

Parameter file attached.
20221206.param (19.5 KB)

Yeah this is a common mistake - if you set SERVO_BLH_MASK you must set SERVO_BLH_OTYPE as well. In your case setting both to 0 is the right thing to do.

Hi Andy,

I tried setting SERVO_BLH_MASK and SERVO_BLH_OTYPE both to zero (left screen shot) but I still need to implement the workaround to arm the motors. I also tried to set the SERVO_BLH_MASK for motors 1 - 4 and SERVO_BLH_OTYPE = 1 (right screen shot) just for curiosity but it did not make a difference.

I really don’t know what the problem with my flight controller is. Is it defective? It is flying well after you arm the motors (almost any flight mode including missions, flips and break). But it’s making me think now that there might be a problem and might not be safe to fly with it. What do you think? The only painful part is I need to always bring a USB Power brick to arm it. Quite embarrassing at the club because people are asking why do you need to do that? Some suggested try betaflight but I have to start from the beginning to learn how to use betaflgiht which is a lot of reading.


Not sure if it will make any difference to arming but having variable PWM low and hi the same defeats the purpose of the feature I would think. Low is commonly set… well low. Also you don’t need Auto Telemetry enabled.
And not that it will make any difference but Low RPM Power Protect On will be fine with the kV of the motors you are using. This is only a problem with low kV motors.


I re-uploaded Copter 4.3.1 firmware hoping that it will fix the currupted flash and will be able to record logs again but it did not help. I also tried to clear the logs from MP but it also did not fix the recording of the logs. I assume that this flight controller has a problem. Can you recommend a better flight controller with the same form factor? I thought of replacing this crap flight controller now.


If I get a chance I will test mine, but got a lot of things going on right now. Nothing wrong with that flight controller.

Hi Dave,

What do you mean by PWM Low and Hi. Do I need to change any ESC settings? Kindly advice. I am happy to test even if the chance of solving the problem is small.


In your ESC settings you posted the image for it shows 96khz for both low and hi PWM. Google “blheli_32 variable pwm” for information. But generally just drag the low setting to minimum. Turn off Auto Telemetry also.

I’ve set the low PWM at its min and has also turn off Auto Telemetry. I’ve also implemented the recommendation of Shawn. It did not fix the arming problem but I feel the throttle response is less jumpy which I like.

This motor arming is really a pain at the back to troubleshoot. If Andy is not experencing it, then its a setup problem on my side that needs to be fixed. But aside from this issue, the quad is really flying awsome. People from my club says first time they saw a quad running on Ardupilot but flies like a racing beast. I cannot comment as this is my first quad. But I have no compalin about how it flies. PERFECT. Just this little arming issue to use a power brick. I think, the logging issue is alrready hopeless.


What’s that music note message on esc 1 there for? And you didn’t have to disable Low RPM Power Protect. Is that the lowest the low pwm will go?

I did not intentionally put that music on ESC 1. I disabled it but it did not help eleviate the problem.


Regarding the Low RPM Power Protect, I tried it based on the recommendation of Shawn just in case this is the root cause. But still no luck.


OK, as I mentioned it can be an issue with low kV motors which you don’t have. But no matter, either way no consequence for you.

Regarding logging, you could try a total reset by loading Rover and then Copter back on. Save your parameter file before and be prepared for some manual parameter resets after. Loading the saved parameter file once likely won’t get you back.

If you want another Flight Controller Matek H743-Slim is a good choice. But, I have had no issues with HolyBro FC’s, have a couple.

Whar ESC did you use for the Matek FC. I better use the same that is already tested.

Try the BlueJay timing - see if that helps - SERVO_DSHOT_ESC = 2