Servers by jDrones

Wiring 4 motors with 4 ESCs to ArduRover

I have 4 motors with 4 ESCs, its all wired up to PixHawk 4 with ArduRover firmware. It’s connected to an 8CH transmitter. I connected motor 1, 2, 3, 4 and their ESCs and I set motor 1, 3 to steer left and motors 2, 4 to steer right in Servo Output settings. The thing is based on my input from RC, it doesn’t match my input from remote control. I know I’m not setting the right settings in place, but I also I couldn’t find any guide on wiring 4 motors/4 ESCs for skid steering. I tried to combine signal wires of 1,3 into one wire so I only enable 1 and 3 channels as suggested in ArduRover guide, but ESCs started beeping and it didnt work. What I am missing?

That should work fine

Can you describe this in more detail? A logfile would help too.

I cant understand why …tried to combine signal wires of 1,3 into one wire … but ESCs started beeping and it didnt work. it should work, and aparently for me looks like the way to go.

No idea, all ESCs started to just constantly beep.

Should I change some settings in ESC and Motor configuration page in mission planner?

Basically, when I move the throttle or the other direction stick to left and right, sometimes 3 motors move, sometimes 1, sometimes 2, can’t remember exactly but it just didn’t make sense with my input and what I was doing in my remote control.a

It could be:
-The ESC’s aren’t grounded
-You’ve not calibrated the ESC’s

That occurs when the safety switch is active - the Pixhawk is not sending any signal to the ESC’s.

What kind of ESC are you using?
Car or aircraft?
Did you complete the RC calibration?
The trim values for each channel should be around 1500us.
Make sure you have a spring loaded throttle (return to center) on your transmitter. Change the RCMAP parameters for each channel accordingly. Ardurover also uses the roll input for steering, not yaw.

@count74 @stephendade
My ArduRover is 3.5, but when I try to calibrate ESC it says please make sure your firmware is 3.5+

As for connection, I think I’m messing up something in connections.

Basically I’m connecting ground pin of 4 ESCs to groun pin in FMU-PWM-out.

Then I’m connecting signal of ESC to M1, M2, M3 and M4

And my PixHawk 4 is connected to Power board through IO-PWM-in port.

I’m using ArduRover and its 4 ESC, 4 Wheel basic car, no servos.

In case it matters, I’m using GoolRC motor + esc combo

Servers by jDrones