Windows 11 support MP?

Does windows 11 support MP? Tried to downlais MP but Dos windws keep loading forever… any suggestions?

Yes MP 100% supports windows 11. can you try uninstalling it and reinstalling. Have you had MP on this machine before or is this a fresh install?

This is my first install in my laptop

Does the DOS window say anything have you tried the uninstall and reinstall, try that and see if it helps? Installing Mission Planner — Mission Planner documentation

Actually the DOS window runs forever and keeps scrolling up with all different codes. Let me try amd uninstall and try to re install it

Hi Aerospace1,
Did you solve the problem?
I got the same problem, if you solve the problem please share it.

Find the MissionPlanner shortcut in the new start menu, right-click and do Properties
In the shortcut tab select “Run: Minimised”
(background image just because…)

Still, DOS like screen (command prompt window) scrolling the screen behind the MP.
Once I close DOS like screen, MP also be shut down too.
So, I tried to reinstall, but it doesn’t fix the problem.
I even restore windows (Windows 11) to the 3 months ago point and reinstall but it’s not working.
Is that because of the Windows 11?
Somebody, please help me.

keep the DOS screen running in the background. @Bingo