Servers by jDrones

Wifi telemetry using DT-06

Has anyone managed to get this working?
My telemetry link works with a Bluetooth HC-06,
but if I plug in the DT-06 instead it does not work.

Can anyone tell how to set up the DT-06 ?

DT-06 is just a particular packaging of an esp8266 compatible chip.
The default firmware on it is probably providing transparent serial, so I imagine it’s a baudrate mismatch causing you problems.
That said, if you’re willing to flash an alternative firmware on the module I suggest you follow the instructions here: http://ardupilot.org/copter/docs/common-esp8266-telemetry.html
I suspect you’ll have a better experience with the device that way.

Thank you for the advice.
Are you sure the DT-06 can be flashed with the ArduPilot firmware?

Only by inference. The reference hardware in the wiki (nodeMCU) is firmware compatible with ESP8285, which is the chip in the DT-06.

got it working.
I had configured wrong udp settings.
Here’s the working setup:

I tried flashing the DT-06.
ESP8266Flasher said flash ok,
but the DT-06 does not work anymore.
I tried all 3 firmware versions.

What do you mean by “not work”?

it’s dead, no led, no wifi.

https://github.com/SmartArduino/SZDOITWiKi/wiki/ESP8266---TTLtoWiFi is the original DT-06 firmware, for you to flash back to it.
It’s a 1MB module, so the 1MB firmware should “just work”. I’m not sure why it doesn’t. Sorry!

thank you for the link but I cannot find the firmware there.

I have found the firmware.
ESP8255 Download Tool V3.6.6: flash error
ESP8266 Download Tool V3.6.6: flash error
ESPFLASHER: flash success but DT-06 still dead

Maybe I have a strange china clone.

I’ve ordered one to test (from China)

I’m curious…

I have switched to ESP-01 which works great.
But the DT-06 is more compact and nicer to handle.

Hi,
Could you share the DT-06 original firmware? I need to flash it back to its original function.
Thank you

Hi,

I don’t have the original firmware, I’m sorry.

Servers by jDrones