Servers by jDrones

Why quad doesn't want to disarm after landing? . Happened two times now (Arducopter 3.6.7)

Maybe only an unlucky situation but on the machine it happened we have had probably more than 2000 landings and never had a problem, than updated to 3.6.7 and happened twice. Went back to 3.6.6 and made 2 flights with more than 30 rtl each and didn’t miss a beat. On top of that all of a sudden 4-5 different repoorts of same prob from different sources. I think it is worth investigating a bit. I went back in the forums and this kind of problem it is very very rare and never showed up as intense as it did in the last 2 days.
Just my 2 cents

1 Like

The flip at landing is a recurrent problem since AC3.4 that isn’t that rare, even if we reduce it a lot since then. But here there is a troublesome coincidence between different unit that flip on landing.
I get the same analyse that Randy, the I-term soften change cannot cause this as the flip appear before the soften.
But those flip appeared on RTL. So we may have an issue somewhere else that was only triggered by recent changes.

My landing failures are always down to point (1) I think. The motors are spinning fast enough for the copter to think it is still flying. Wouldn’t it make sense to look at the throttle input in some circumstances?

Flew again today, still with 3.6.7. First landing was in loiter, detected well, copter went idle and disarmed the motors.
Then I attempted a mission, marred by GPS glitches - it should’ve been a racetrack at 80m but copter shot up to 250+. Recovered, landed in loiter and this time around landing was not detected, switching to stabilize didn’t help either, one prop hit the ground then CRASH_CHECK disarmed the vehicle.

Here isthe log, I hope it is useful to find the problem, tomorrow Iwill try both 3.6.6 and 3.6.7

Can’t seem to be able to find 3.6.6 or convince MP to show it, even if it’s there in the pulldown menu for older firmwares.
Anyone can help me with the apj for Holybro Pixhawk 4 ?

@ThePara,

If the latest beta MP is loaded then AC3.6.6 is available.

Re the climb to 250m, it is caused by the EKF becoming confused because of high vibration levels. the Z-axis is about 40m/s/s which is in the grey zone (which stretches from 30m/s/s to 60m/s/s) which means that altitude control will sometimes work but sometimes it will have problems.

We are discussing more ways to improve resistance to vibrations and I expect we will add a vibration failsafe to 3.7.0. The underlying cause though should still be fixed so please check this page re vibration isolation hardware.

I’m going to go a step further from now on I think and recommend a flight controller with built in vibration isolation like the Cube, the CUAVv5 or the Holybro KakuteF4.

I’m going to go a step further from now on I think and recommend a flight controller with built in vibration isolation like the Cube, the CUAVv5 or the Holybro KakuteF4

Not a great answer for small racing copters however - seems at odds with the desire to support more FC’s. And unfortunately the vast majority of people will think “well CleanFlight/BetaFlight/… manage to make it work so ArduCopter must be broken” :frowning:

Thanks for looking at it, Randy.
It’s actually a Pixhawk 4, with one IMU mounted on a piece of hard foam, just like the Kakute, and the FC itself is mounted using a double layer of silicone sticky tape. And being a Pix4, all the wires are silicone AWG 28 - there’s no servo-style wires of thicker gauge running to it. And it’s a very compact copter, at 650 mm diagonal with 15 inch props, so the Z-axis vibes may be generated by prop airflow near the frame.
Now, after running a proper log browser, thanks to @ChrisOlson, some data became evident. Due to not wanting to squint while looking at the copter, my test flights were flown mostly facing north. And all the GPS glitches occur with the copter tilted to and accelerating north. No glitch was experienced flying E, W or S.
What happens is everytime the copter leans north, the GPS flickers by one or two sats, hdop flickers as well and the GPS VZ takes a beating, generating a glitch


The big yellow sinusoid is the latitude, those sharp blue/red spikes are numsats/hdop, the green/green/dark red curves are altitudes (desired, gps, baro) and in purple the misterious GPS VZ parameter

@ThePara,

… but to be clear, the altitude hold problem is not related to the GPS quality. It is possible to make the EKF use the GPS altitude (by setting the EK2_ALT_SOURCE parameter) but by default it uses a combination of the accelerometers and barometer. In this case it is the vibration that is affecting the accelerometers and causing the troubles so I think some changes to the vibration isolation are required. It also may be possible to reduce the EKF’s reliance on the IMU (and increase it’s reliance on the barometer) by reduing the EK2_ALT_M_NSE parameter (mentioned here) but the best solution is a physical solution.

3 Likes

Hello,

It happened 2 times to me today, that the copter did not recognize the landing. I landed manualliy once in Loiter mode and once in Position Hold mode, both times after touching the ground, I could not disarm and the copter speed around. The good thing which is working is the crash detection. But unfortunatel I broke 3 of the 4 propellers so I could not try a third time.
I never had an issue with that copter before (approx. 100 flights) It seems that it was after upgrading to 3.6.7. I do not know which version I was running before.
Could you please tell me when you did make changes on the landing detection, so that I can go back to that version before.
Is there anything planned to improve the landing detection?
Is it perhaps an idea to force disarm of copter if both sticks are moved to bottom right/left.

Best regards

Harald

i experienced a similar situation recently where it landed in RTL mode, but it did not disarm while on the ground and holding the stick down and to the left would not disarm. It was still in RTL mode when I tried the stick, but maybe if I had switched to pos hold for example, it would have disarmed? Maybe not since the copter did not know it had landed even tho it was sitting on the ground… is it possible to disarm with the sticks in flight?

i had to unplug batteries to shut it down

something that might help diagnose the issue is, in my case, the landing was very hard… most of my landings are gentle and have never had a disarm problem in those cases

I programmed now a switch on my transmitter where I can use the emergency stop of the motor. Think that is a better solution then catching the copter by hand :slight_smile:

1 Like

Hi,

My craft is also suffering from the “not detecting landing - bouncing up and down” error… Usually in assisted modes (anything from Althold to Loiter), when I am trying to land, the craft lands let’s say perfectly, it is still turning the motors on higher than needed rpm, and it is pulsating. Throttle is set to minimum… And, of course, it is not disarming…

Today I was trying to land in Sport mode, the descent speed was a little bit fast, and the craft bounced back into air for about 50 cm and continued to jump… I pushed the Th to raise the craft and land again gently, but in that time it turned about 45 degrees, and has flown into a tree not far from me, even after I cut the Th… Two motor mounts broke off, but the craft, the props looks OK…

Usually (and this will be the normal procedure for me from now…) I can only land normally if I switch to Stabilized mode for the final descent.

If I had to guess, and we do without a .bin log, I’d say barometer not covered and vibrations.

I also had a un-commanded lean (then tip-over) failure yesterday (using v 3.6.8) - but after “land complete maybe”.
Would the Log help to get to the bottom of this?
Any hints are greatly appreciated!

I have had similar problems when i was using gps blend, it didn’t disarm and flipped over. After disabling gps blend never happened in around 400 landings.

Hmmh… GPS blend ?
But I have set GPS_AUTO_SWITCH to 1 , meaning “Use Best”.
Wouldn’t this then mean that there isn’t even any blending happening, even if GPS_BLEND_MASK is set at 5?

Any more hints?

I am not saying that is your prob too but if i was you i’d try to use just one GPS and see if your probs are gone. I suspect there is something going on about the double gps that is not right.
It is an easy test anyway, just try to see if with just 1 gps your problem disappears.

I now tried it with GPS_AUTO_SWITCH set to disabled (instead of use best), but this did not result in rtk fixed either.

Servers by jDrones