Which version do I need to use for Pixhawk 4 flight controller?

G-d willing

I am having a Pixhawk 4, which I flashed using this link:

The problem I am having is that the battery is not recognized, hence no ESC calibration can be done.
I was told that ArduCopter cannot work with the Pixhawk 4, but then someone else told me that it is just a matter of the right version.
Can someone please help me with that? Which version should I use, and where do I get it from?


You are using the right version. But you do need to have a battery monitor hardware connected and correctly configured for it to work.

They are wrong. The link you posted is to the latest -Dev version. If you lack experience with Ardupilot you should probably use current Stable or the latest Beta version.

Well I tried doing so. I went yesterday to a place that is experienced in building drones (they built drones with ArduPilot, and used several flight controllers including the Pixhawk 4).
On the Battery Monitor screen, it does not recognize any battery I use. I tried with several batteries (since I thought that the specific battery I am using is not good).
So the guy told me that it is impossible to use the Pixhawk 4 with ArduPilot.
But another friend I have said that it is possible, however there are some ArduPilot versions that are not good for the Pixhawk 4.
Can you please advise me on a battery monitor to work with?

Thank you. I will try to reinstall the latest version again today.
Since I do not have experience with ArduPilot, what are the “risks” in using the beta version?


Reading the docs helps:


We use multiple Holybro Pixhawk4 here and their supplied battery monitor works fine.

No significant risk using Beta. There is risk with “Latest/Dev/Master”

BTW- "Use the search feature here for “pixhawk 4” and show your friend who says it won’t run on Ardupilot the result.

Any power module will work from HolyBros own PM07 to the cheapest generic “Pixhawk Power Module”

I thought you meant something else. I do have the PM07 with me.
I will be happy to show my friend he is wrong. It will save me money of buying another flight controller.

Thank you very much.

I have the PM07 by Holybro.
The documentation does not show how to configure this battery monitor.
Can you please advise me on the correct configuration I need to do.
I am using a 6S 8000mAh battery.


The Holybro website has Ardupilot setup info for the PM07. Wouldn’t be there if Ardupilot wasn’t supported eh :slight_smile:

I don’t have a Pixhawk 4 but it’s easy enough to find info!

1 Like

Wow. Thank you very much mate. G-d bless you!.
I highly appreciate that, I will be so glad to show my friend he is wrong about that.
My friend almost convinced me to buy a different flight controller.

:+1: Get her flying!

1 Like

I cannot follow the steps that were advised here (http://www.holybro.com/product/pixhawk-4-power-module-pm07/) since the fields are read-only. I can fill the top 3 parameters but not the 6 calibration fields. Does anyone know what is the problem?

Power cycle the Flight Controller and then connect a battery.

Thank you very much for the quick tip :call_me_hand:

I have no idea what is the problem, if its related to the flight controller or to the motors, ESCs or something else.
I just flashed the FW on my Pixhawk 4. I started from scratch, calibrated the compass, I calibrated the accel, I did radio calibration and battery monitor.
However, when I am getting into ESC calibration, this process cannot be completed since the motors beep for some type of a problem (according to the ESC doc, the normal/reverse direction of the throttle is incorrect. However, the throttle direction is correct. I even tried to calibrate the ESC with reversed throttle direction.
No matter what I do, I cannot get it to work. I really need help with this.

Those power monitor settings appear read only when you have a known power monitor set, as you do. Generally there would be no need to change the read only values in that case.
You can set the power monitor type to “Other” and do the voltage and current calibrations youself when you really need to.

If you’ve done the radio calibration properly, then do the “all at once” ESC calibration, you will need to press you safety switch during that procedure.

I don’t have a safety switch in the Pixhawk 4. There is a button on the GPS that comes with it, but it does not do anything when pressing on it - it does not change any light nor beep.

Disable the safety switch usage (in the firmware) by setting these in the Full Parameter Tree

Use this Semi-Automatic ESC calibration method
No need to touch your radio :slight_smile:

I followed your instructions (changing the parameters and the semi-automatic esc calibration. But I am facing the same results. There is a long tone from the Pixhawk (for around 1 sec) then I hear (from the ESCs or the motors - not quite sure from which one exactly) 2-beeps, 3-beeps, 4-beeps and then again 2, 3 & 4 beeps over and over again.