Where are we on the 'Bad LIDAR health" problem?

Hi all-

After knocking myself out getting everything connected and configured on our Pixhawk4-controlled quad with an SF11/C rangefinder (and latest Arducopter) , I find that pre-arm fails with the ‘Bad LIDAR health’ error. I have found a few references to this problem online, but they seem to boil down to:

  1. Set RNGFND_LANDING = 1 (if you’re flying a plane) which is not applicable to a quad and soesn’t seem to lead to rangefinder use during landing anyway

  2. Nothing at all if your rangefinder is on a quad.

If there really is no fix for this that would be a real bummer after all the effort it took to get everything together! The SF11/c is powered through the serial port btw, but I have tried powering it directly from the PM-07 board as it draws up to a max of 200 mA. I’ve seem mentions of delaying the startup of the rangefinder but have not gone that route yet.

Any suggestions would be very welcome. Thanks.


You might want to try a different serial port. I had lidar startup problems on the GPS2 port. On Telem 2 it works solid.
Dedicated power supply would still be recommended.

Thanks for the suggestion…I’ll try it this afternoon.


I found this thread looking for answers to the same problem. I have an SF11/C which I tried to run with arducopter 4.0.5 3DR px4 pixhawk controller. I got “Bad LIDAR health” no matter what I tried. Then, internet let me on a walk which ended up at https://lightwarelidar.com/apps/faq#hc-how-to-connect-our-devices-to-a-pixhawk-1. Reading this page, I learned that it is possible to upgrade the Firmware of the SF11/C using the “Upgrader tool”, linked to http://support.lightware.co.za/LightWareUpgrader-win-x64-1.56.0.zip. I downloaded, unpacked and ran this tool (the EXE file) and connected to my SF11/C. It said it wanted to upgrade. The old firmware version was V1.2.1 and it wanted to install 1.5.1. I let it upgrade, and WOHOO - it works!

Additional information:

  • I run via SERIAL4 (not I2C)
  • With the old firmware, whenever I connected my LIDAR unit, the GPS and the external compass would stop working. With the new firmware, all works fine.
  • After upgrading, it seems the Lightware Terminal 1.3 doesn’t work anymore. But I don’t care right now, the LIDAR works perfectly fine with the arducopter 4.0.5 with the new firmware.

I hope this info can be of use to others.

1 Like

lidar VL53L1X
After updating the firmware to ArduCopter V4.1.0-rc3 (181e47b1) The messages contain a permanent error “bad lidar health”

Hey, I have the same problem with a Lidar SF30/c and a pixhawk v6c, do you know how to fix it?