When GPS lost, copter use FS_EKF_ACTION: EKF Failsafe Action and switches to althold mode and starts to accelerate

hello again, lok a new log pls…

hello again, lok a new log pls…

I have no idea what you are attempting to accomplish. I don’t see what you are describing and there is no bug.

You didn’t take the advice to use the proper firmware for that board and you didn’t set the Initial Tuning parameters. Good luck.

Thanks for looking into this @dkemxr

@vmv007 please do the following, before we can help you:

  1. you must upload pixhawk1 firmware version ArduCopter 4.1.3 or even better 4.1.4-rc1
  2. read the extensive documentation
  3. You need to properly tune the PIDs as per documentation

pixhawk1 firmware does not working i this FC (already tried)! fmuv2 and fmuv3 is a good firmware

why then the copter accelerates?

If it’s a Pixhawk 2.4.8 you are wrong. Countless people have used Pixhawk1 on those FC’s; I did when I had a couple.

why is everyone posting fmuv2 and fmuv3?

Pixhawk1 is the correct firmware for that Flight Controller.

you writing here about fmuv3, i why when i load pixhawk1 firmware its does not work?

Pixhawk1 is the correct version for the Pixhawk 2.4.8. It includes Fmuv3 along with some other details.
Pixhawk1 Hwdef

Download the ardcucopter.apj file from here and use the “load custom firmware” option in Mission Planner to flash it.

Or suit yourself and don’t.

1 Like

ok, i will try this! thks!

If it doesn’t work use QGC and select Pixhawk1 as suggested in those other threads.

1 Like

1.Flashed the firmware pixhawk1 using QGC! It works! You were right!
2.I try to learn how to set up DNS filter! New DF log and imu batch sample is the same option? In MP i see only imu batch sample

Don’t worry about FFT and all that stuff yet.
You need to go back to the documentation and steps in MissionPlanner.
Start by setting up correct voltage (and current) monitoring then use the Initial Parameters section and accept everything it offers except the T-Motor Flame ESC bit.

Set these to gather data for the Notch Filter configuration.
Hover for a while in ALT Hold mode and maybe a few gentle movements, nothing radical - let’s see that .bin log file and we can work through the next steps.

I did everything according to the instructions as you gave. firmware pixhawk 1, dns filter…pid look good? i dont see any oscelations/
when i try to turn on atotune i see messege - failing to level, pls tune manualy.
what can be?

Incorrectly. You have the Dynamic Notch Filter configured for throttle reference with no hover throttle value configured. And you have the INS_LOG_BAT_OPT still set to 0 so presumably you have not checked to see if the filter configuration is working.

Your Z vibration is still too high.

Ok, thks, i will check it

  1. I think i have found my mistake about Dynamic Notch Filter…
  2. what should I do to reduce vibrations along the axis Z or DNF will help with that?
  3. to see if the filter configuration is working i need to do ## Post Configuration Confirmation Flight and Post-Flight Analysis ?