Servers by jDrones

Weird crash while in Auto Mode


(Buzz 11) #1

Hi Guys,

I had a crash while flying in Auto mode for a mapping mission.

If anyone can help me make sense of the bin and telem log file it would be great.

I can see that despitch and pitch go their seperate ways just before the crash, but i cheked after and servos are still attached and working with servo tester

Have been looking at them for some time, but don’t understand why the plane decided to go down abruptly??!!

https://we.tl/t-m2suL84wL6 BIN FILE
https://we.tl/t-SLHlKfMQXC TLOG FILE

Thanks


(tridge) #2

Hi Buzz,
The only time I see the attitude go off in that log is when it is switched to MANUAL mode. Did you deliberately switch it to MANUAL?


Cheers, Tridge


(Buzz 11) #3

Hi Tridge,

Thanks for your reply.

I did not, radio was put aside just after takeoff. As a matter of fact, just after the crash, I swithed back from auto to manual to make sure to stop the throttle just in case it survived lol (long shot, but a habit of mine :slight_smile: )

Another weird thing, is that at the same time i can see throttle going below 1040 which is the failsafe, but this doesn’t appear in the teleme log, and in case of failsafe, arduplane shouldn’t switch back to manual ??


(tridge) #4

If you have THR_FAILSAFE=1 it will go into failsafe. For some reason you had THR_FAILSAFE=0, so no failsafe.


(Buzz 11) #5

So what do you think is the cause of this switching back to manual ?


(tridge) #6

presumably your receiver sends a high value on chan5 when it goes into failsafe? That would be worth testing.
Certainly from the point of view of ardupilot it changed to MANUAL because

  • FLTMODE6 was 0 (manual)
  • chan5 went above 1900 (so switch position 6)
  • THR_FAILSAFE was 0 so it didn’t check for radio failsafe

(Buzz 11) #7

Yes I have an ezuhf, and when I set the failsafe I did not think about the switches and the flight channel switch was in Manual :((( !! What a silly mistake …

THR_Failsafe was 0, because when it is doing a mapping I don’t want it to go into circle if radio failsafe, but to continue the mission because I have an RFD installed on it.

How who you advise me to configure it next time, so when I am in auto mode and I have a radio failsafe or I shut down the radio, it stays in auto mode doing its mission ?

Thanks a lot for your help tridge


(Paul) #8

Buzz1,

I’ve been testing DIY control systems so I had be prepared for possible failures. A good way to do that is to configure auto landings for your plane. Best to make a test airframe for flight testing and working out the auto landing settings.

Configure the flight controller to continue the mission if it has a failsafe event. Have the flight controller detect failsafe with both the throttle and GCS failsafe options.

At the end of the mission is the auto landing, so if you never get control back at least you’ll get the plane and your mapping data back.

Towards the end of the mission you can check to see if you have regained control by momentarily switching to manual flight mode. If it responds, good. If it doesn’t it will remain in failsafe, complete the mission and land nearby.

I attached notes from my auto landing tests.

Good luck,

Paul

arduplane-autolanding-v1.pdf (804.0 KB)


(Nathan E) #9

My similar thoughts as well about Throttle Failsafe.