"Waiting for mavlink heartbeat" problem

Hi , i have a pixhawk autopilot (https://ae01.alicdn.com/kf/H35e649a173364ef58ac85c4bb12f69b2X/Pixhawk-PX4-PIX-2-4-8-32-Bit-u-u-kontrol-r-sadece-kurulu-TF-kart.jpg_Q90.jpg_.webp) and 2 version of minimosd(https://image.robotistan.com/apm-mini-osd-karti-42659-11-O.webp) . When i start pixhawk and my video transmitter , there is live video on my lcd and old version of osd overlay to screen “Waiting for mavlink heartbeat” . When i try the newest osd, there is minimosd panel figures o screen but all values are zero and says no data.On the mission planner via usb , it has live data. Both of my osd’s cant connect to pixhawk or cant receive messages from pixhawk. I dont use 3dr radio there for i try to connect both telem ports(Telem1 and 2)but nothing change. I search the forum and another platforms for the same problem. I tried everything about fixing this problem (charset update,firmware update,using arduino for clearing epprom,reseting osd,change wiring, set pixhawk serial protochol and other settings,buy mwosd software etc. ) but nothing change.I borrowed another pixhawk(same as mine)and i have tried to use both osds on new pixhawk but nothing change. it is ridiculus and meanless.I stucked on it. My fpv plane ready to fly but
I can’t fly because I haven’t been able to solve this problem for 1 year. Please help me.I’m about to go crazy.

List item

The new default communication protocol is Mavlink2, where the old style OSD units only accept Mavlink1.
assuming you’ve got the OSD device connected to Serial1 or Telem2 - adjust to suit your set up.

1 Like

I did it several times. Even serial0,1,2. But nothing changed.

Well it might be a wiring problem. Can you get a pic of the flight controller and OSD wired together?

Serial0 is the USB port and you shouldnt change it, make sure that is SERIAL0_PROTOCOL,2

I tryed several combination of serial settings. But nothing change. Im not close to my plane but my wiring diagram same as that. https://ardupilot.org/copter/_images/MinimOSD_Pixhawk.jpg
Also i changed tx rx cable , change sockets, cables etc. Nothing changed.

There are 2 ground pins on osd and 1 blk pin. I tryed all of them but no way.

Only connect these highlighted pins to the flight controller Telem port

Also set


along with

I tried this serial settings and cable combination before but i ll try it again and i will get back to you.

Nothing changed. I configured the sr2 like sr1 but again failed.

You dont have anything plugged into Telem1
What is plugged into Telem2?
Where are the actual OSD wires going to?

Normally i use telem 2 for the osd and telem1 is free. İ said before, i dont use 3dr telemetry. At this picture , i used telem 2 for osd.When i use telem 1 , telem 2 is empty, or use telem 2 than 1 is empty.I use 6 pin socket for osd but 4th and 5th cable is blind.

Yes, understood - thanks.
Can you show your cable in whole, from end to end?

I cant show it now but Cables have attachments. One side of them black and other side is colored. I soldered and tested them. First cable on telem 1(red one) goes to 5v+ on minimosd(minimosd side red too.)Second cable on telem 2(Black) goes to RX on minimosd(OrangeCable),third cable on telem 2(Black) goes to TX o the minimosd(Green cable) and last one(6th cable on telem2) (Black) goes to Ground on minimosd (Brown Cable). There are pictures of both sides above.

I think its about software. İ have pixhawk 2.4.8 (https://st2.myideasoft.com/shop/cb/27/myassets/products/067/pixhawk-2-4-8-ucus-kontrol-karti-seti-19335.jpeg?revision=1665361746) .Can anyone give me right firmwares and charset for both pixhawk and minimosd ,and also pixhawks right settings on mission planer ?

Use MissionPlanner to save your parameters to a file and post that here.

MinimOSD Nightghost-Extra is the firmware I used, it was the latest most up to date for these OSDs.
If you see any options for PX4 or Mavlink or similar, dont choose PX4.

I choose MAvlink versiyon of firmware. Is it wrong ?

pixx.param (16.9 KB)

Mavlink is the correct choice I think - it’s been a long time since I messed with these OSDs…
Set these parameters, assuming Telem2 is the chosen port.

BRD_SER1_RTSCTS,2  // back to default setting in case you use this port for something else
BRD_SER2_RTSCTS,0  // disable RTS/CTS
SERIAL2_PROTOCOL,1  // set Mavlink1

all the other SR1 , SR3 , SR4 values can be 0 unless you’ve got something plugged in that needs to know your flight information.
The SR parameters are for devices that dont request specific information, but are just waiting for it to be pushed to them. These OSD devices dont request anything, they just sit and wait for the info, so you need some SR2 settings (but not all the others).

Thank you very much for your interest and help Shawn. I ll try new codes that you advice and than i ll feedback to here.

I do everything that you suggested but no way.My older version of minimosd says waiting mavlink heartbeat , new one says no data . I going to buy a new minimosd . If it doesnt work properly , I’m going to give up on the autopilot project or buy a different autopilot system.