VTOL -- freeman2100 vertical take-off and landing fixed wing +pixhawk

yes. Note that I only put the params that are different from what MFE had. You still need to setup the servo functions, frame class etc. This just gives you the tuning I used.

If I had already installed the original MFE params and flown the Freeman then doing what I said in the previous post would be ok? Would that be the same thing for the Striver - install first the original MFE params and then load your updated params?

yes, sorry for not being clear, updating fw then loadng my params will work

1 Like

I noticed that your Q_TILT_RATE_UP is 30 while the original MFE Q_TILT_RATE_UP is 60. Will this not slow down the front tilt motors transistion from forward flight to hover in Q_ASSIST situations?

yes, it will. Higher values lead to some oscillation in back transition however.
I’m working on a change to allow that to be higher without causing instability in landing.

Wealth of infomation, great photos as well!

hello, i wonder if some one can helpme a little with my freeman2100, im stuck in the parameters. i cant arm the motors and calibrate esc. i have a warning that i need AC3.3+ version. woud you share your firmware and param file? because i cant make it work. thank you

Hi Tridge,
I would like to test official firmware instead of MFE version and I wanted to load your set of parameters, but one got my attention… INS_HNTCH_MODE … I had it set to 0 and you have it set to 1 which is based on description recommended for multicopters… So my question is:
Is really OK? If I set it to 1 might I use HNTCH parameters which are in your set of params or do I have to go throught recommended procedure?
I would use option 4 but it is just for boards with more them 2MB of memory but Pixhawk 4 which I use has exactly 2MB so I am not sure if it would work…

Btw… two parameters are not matching mine … Q_BACKTRAN_MS and Q_TILT_ENABLE Do you know why?

Thanks Jakub

yes, it is fine. You do need the other HNTCH parameters as well.

none of the boards have “over” 2MB, so option 4 does work fine with Pixhawk4.

that is from the 4.2.x test version I was running. It should fly fine with 4.1.6, although there are some improvements in 4.2.x.
Cheers, Tridge

Hi everyone, finally i made the maiden flight of my freeman2100 in quad mode, i tried Q Stabilize, Qhover and QLoiter.
everyting went ok because it did not crash, but the control looks “lazy” and drifting. also there is a vibration in motors. and the yaw drift a lot. im trying to understand the log, but if someone can helpme reading why i have this oscillation and is so slow in respondig to pitch, roll and yaw, maybe something with PID’s. in my setup i use a tattu 6s22000mah (yeah, its a heavy battery)
here are a video and the log file.
video: https://drive.google.com/file/d/1R2s2gCwyz69-jbRE3DkpdleyKdiR6oV7/view?usp=sharing
log: https://drive.google.com/file/d/196kVDU4gRar5qDJbM-E-Ov-ywazPdINP/view?usp=sharing

1 Like

@GregCovey or @tridge can helpme wit this issue that i post previously?

I had a look, and there are a few key issues.
First off, the harmonic notch is not properly setup. As you didn’t have INS_LOG_BAT_MASK set I can’t do it precisely for you, but I suggest the following parameter changes:

INS_HNTCH_ATT         80.0000
INS_HNTCH_BW          56.0000
INS_HNTCH_FREQ        111.0000
INS_HNTCH_REF         0.3760
INS_LOG_BAT_MASK      1
LOG_FILE_BUFSIZE      64
Q_A_RAT_PIT_I          0.2000
Q_A_RAT_RLL_I          0.1500
Q_A_RAT_YAW_P          0.0700
ARMING_CHECK        1
AHRS_EKF_TYPE       3

that sets the harmonic notch to what I use, but also enables the logging needed so the next flight log will give enough information to get the filtering right.
I’ve also fixed your AHRS_EKF_TYPE, which was set to 2, but EKF2 was enabled, which means you were flying on DCM, which is likely why it felt soft.
Other things:

  • you need to redo the compass calibration outdoors with GPS lock. The compass calibration is very bad, and had no scale factor set. Make sure the compass is well aware from any wires carrying significant current
  • for the next flight, do a full 360 degree yaw while flying in QHOVER. That will give me data to check your compass calibration

Hi tridge today i tried to set HNTCH filter parameters…
I just enabled INS_LOG_BAT_MASK =1 and LOG_ FILE_BUFSIZE = 64 … Flown VTOL in QHover mode at center throttle stick about a minute and land disarmed.

Download loaded the log and plot the log using FFT but there is no IMU1 acc and Gyro information.

Default LOG_BUFSIZE = 80 tried that also but same result…is that I’m missing anything to get peak frequency?.

I’d need to see the log to know

Hi tridge here is the log file for your reference
https://drive.google.com/file/d/1Qd3WrTC_rLtumjBB7ETXTLnV_4PKlBfx/view?usp=sharing

https://drive.google.com/file/d/15cpO30uoRQtC3LWPpeoFERKiiZGgOt32/view?usp=sharing

thankyou for your time, i will check and update all the parameters, and making all the calibration.
also in my param list the value INS_HNTCH_ATT (wich i have on 40) only allows me a range up to 50 (really far away from the 80 that you have)
i have a Firmware Version V4.1.6

i use your parameters and it flown so much better and steady, the yaw still drifting, but everyting else went better. here is a video and the log. how can increase the sharpness on yaw? and the altitude was hard to keep steady.
video: https://drive.google.com/file/d/1SQjUfQg3GlioMi7-eb89rBLQizkTqVdg/view?usp=sharing
log: https://drive.google.com/file/d/17UswiJWXbMQEG_CDaNXqG7UWsd8jpaxp/view?usp=sharing

There are some audible oscillations in your video. Are you sure you have followed the VTOL tuning process subsection manual tuning before autotune?

I had yaw oscillations similar to your video but i applied the tuning steps from the wiki to it as well. One thing to keep in mind for yaw is the I gain should be 1/10th of the P gain in yaw axis.

From a post by leonard hall, i read that it is very important to tune the D first and then go to the P and I parameters because tuning the D allows for a maximum possible P term. He also stated that it is important that the guide is followed step by step in their appropriate turn.

in my first video i have terrible oscillations, very loud and visible, in my second vid (last post) it flyes better, and reading the logs i think that i have some oscillations, but they are about 2-3Hz. maybe is because i was flying with arround 20-25km/h wind. anyways i will follow the step by step tuning process and try again. thanks

Can I ask how one may be able to check compass calibration by doing a complete yaw circle?