Vision based precision landing, codes getting error in Raspberry pi terminal while uploading

Hello Everyone!
I am working on precision landning using below link.


First ensure the above dependencies are already installed.

There are two main components:

  • vision_landing, a python script
  • track_targets, a c++ program

track_targets must be compiled and installed into the main directory before vision_landing can be run. vision_landing calls track_targets to do the actual target detection and vector calculations.

git clone
cd vision_landing/src
cmake . && make && make install

You should now have a track_targets file in the same directory as the vision_landing script (the root of the vision_landing project).

I have completed upto this. In terminal in which directory should I run below command?

aruco_calibration live mycamera_calibration.yml -m vision_landing/calibration/aruco_calibration_board_a4.yml -size 0.033

I am getting error like this after uploading.

1 Like

Have you installed/build OpenCV and ARUCO Libraries as required ?

Yes. I have installed both.

I have installed both

Screenshot (25)


If you have not deployed using make install, you need to add path to the libs (.so) into your environment

Hi, Thanks for the quick reply.
Sorry, I am not good at coding stuff. I am new to this. Learning it online. So if I ask anything silly pardon me.
I have done as follows;

  1. Installed aruco using cmake
  2. Downloaded OpenCV from a github account and extracted
  3. Tested the camera using OpenCV
  4. Installed dronekit
  5. Installed vision landing

Now I am stuck in camera calibration command
I don’t know where to put those command;

aruco_calibration live mycamera_calibration.yml -m vision_landing/calibration/aruco_calibration_board_a4.yml -size 0.033

I hope above one is a single command.

It is giving error message like this.

Same answer as earlier… the command does not find the library (that is a Shared Object type). It is either not located in the $PATH environment variable or it has a different name.

Hi sir,
I am doing image calibration.
Its keep showing error. Please let me know what should I need to do?

Screenshot (31)|690x387


First of all , you have a low voltage warning… Please use correct power supply
What is the load on CPU ? You can check with Htop


I am using 5 volt and 5 ampere power module.
But It is keep showing that voltage warning.

I am attaching few screenshots for your reference.

I have put below code in vision_landing.conf

Marker tracking history - number of frames that each marker is tracked for active marker transition


Marker tracking threshold - percentage of frames in tracking history that marker must be detected to be activated


Its been a long time I worked with Aruco, cant tell if the numbers are OK
@anbello can probably help better at this stage or @LuckyBird

Oh… btw how did you fixed the .so lib issue ?

I got it fixed with the follwing commands;

pip uninstall opencv-python
pip uninstall opencv-contrib-python
pip install opencv-contrib-python

The calibration works fine for me. But it is not creating “mycamera_calibration.yml” file. Can you help?

So you reloaded the Aruco libs from contrib, not exactly @fnoop release. I guess it will do the same.

Now, what should I do? Any help?
It’s been two weeks since started working on…


What camera are you using? If you’re using the standard raspberry cameras - v1 or v2 - you don’t really need to calibrate as vision_landing provides calibration files already.
Hey ppoirier, nice to see you’re still alive and droning :slight_smile:

1 Like

Thanks for the reply,
Using v2.1 Raspberry pi camera…

So, I can skip the calibration part.
Am I correct?

Hello @fnoop nice to see you here as well :upside_down_face:
Thanks for helping on this old but still fascinating project

1 Like

Hi Fnoop
Could you please tell me what is the next step?
I have skipped the calibration part as you said.


Uploaded commands as follows

sudo systemctl start vision_landing
sudo systemctl stop vision_landing

Nothing is happening

Uploded this too
./vision_landing --input /dev/ttyS0 --markersize 0.235 --calibration calibration/raspicamv2-calibration-640x480.yml