Vision based precision landing, codes getting error in Raspberry pi terminal while uploading

Connection refused - is that for the input port ttyS0? Have you verified that your raspberry is connected to the autopilot? Make sure there’s nothing else currently using that port as well - only one thing at once can use serial port (sudo lsof |grep ttyS0)

Connection refused - for input port ttyS0.
Raspberry pi was connected to Flight controller.

Hi fnoop

For your refference. The pictue is showing
Pixhawk 4 is connected to Raspberry pi, error I am getting and code you have given are tried.
Kindly look into this.


It shows the successful connection was made with ttyAMA0
I guess you have disabled bluetooth to get acces to the UART ?

Yes I have disabled it.

Ok, have you tried launching with ttyAMA0 ?

Yes. I did that. But nothing was happend.
Keep showing “Connection refused sleeping”

Don’t use ttys0 if you’ve configured ttyAMA0. Make sure you’ve not got anything else connecting to that port, like mavproxy in your screenshot.

Sorry, I dont get it.
Please elaborate.


Sorry but I think you need to get more experience with FC - CC before attempting this kind of project. You cannot ask for answer for every steps on the process, you need to walk before running

Thanks for the support.

Yes ppoirier is right - you need to get some understanding of the basics before attempting something more advanced like vision based automated activities. Maverick will solve your installation/setup issues, to a point, when I get the next release out.

Thakyou so much.