VERY short telemetry radio range (less than 5 meters)

Hello, I bought telemetry radios 100mw 443mhz from Banggood and connected one to my drone another one to my laptop and they worked fine, I even tried to go to another room and it still had signal, then I went outside to the field, connected one to the same laptop I used inside, took off and when it reached 4.3m altitude it disconnected, I landed tried again and it wouldn’t connect. So I went home tried again and it surprizingly connected! Even with doors closed in another room the telemetry worked great! Tried disconnecting FPV but that didn’t work. Tried to change driver but no luck either. Here is a screenshot from Mission Planner Sik Radio Settings:

Ignore that the remote radio is disconnected, I don’t have my drone plugged in but it is basically the same thing as local radio!!

Any help will be appreciated!

Could you please connect and take the same snapshot, as well as check the Telemetry log (tlog) and plot RSSI, rmrssi, noise, rem noise.

I would like to rule out some common mistakes.

Usual suspects are:
1.Different freq settings, duty cycle and power
2. Asian vendors tend to place simple wifi antennas instead of 433 ones.
3. If you are in EU, 433 is an open freq, so even remote garage doors work in there (tons of noise floor), you have to check channels one by one to find the cleanest in your flying area.
4. If RSSI even indoors is well bellow common thresholds, then one of them is probably dead and only connects through pre amp.

@Dimitris_Stefanakis How to plot the rssi, interference, etc… ?

Nevermind, most info is in the screenshot (check RSSI and noise at upper left corner)

Your setup seems ok.
RSSI vs noise seems ok.
RSSi levels (~90) seem ok if both units are close.

You could do the same check outside, to see what’s going wrong. Also you could uncheck op recent and ecc. Finally by a pair of legit antennas.

If nothing from the above work, then most probably the clonie chipset sucks…

1 Like

Okay, I will make the test outside another day and send here the results! Thanks!

Is it normal that my antenna is the same exact length that the fpv 5.8ghz one?
And THIS is the exact model I bought

They may look the same, but if they’re correct the actual antenna wire inside will be a different length. You should test this with the 433MHz antennas that it came with. 433MHz and 5.8GHz will have different antennas, even if the connections are the same.

That’s interesting:
New Upgraded 3DR Radio V2.0 Telemetry 433MHZ

What would be “New” and “upgraded”? Not the firmware as your screen shots show V1.9…

I had a set of telemetry radios that came with 5.8GHz antennas. To be sure you will have to pull the outer tube off from the base off the antenna. A 433MHz antenna should have an active part that looks like a coil/spring (normal-mode helix). A 5.8GHz antenna will just have a short stub of wire and a dipole tube.
Or find a known good pair of 433MHz antennas and test with those.

But if the antennas would be incorrect frequency i would have very short range inside too, right? Because this is not the case.
Also I remember there is a big antenna nearby (that looks like a big analog TV kind of antenna but pointed up) maybe it has interference with that!

Ran the test outside in another location, disconnected after takeoff again! I changed the settings that you have suggested but it doesn’t work…
Here is a screenshot of tlogs from tower

At glance, it seems you have terrible interference.

You receive at 46 and the noise floor is 62!!! Basically covering any transmission. Even at the beginning with RSSI 46 you have 41 noise (in short only 5 left to play with)

I wish you could do the exact same test that you did at the first place with mission planner Telemetry screen or grab a telem log for a few minutes.

If indeed you have noise issues, a forum search will show you that most, used external usb hub, to clean interference from usb, others used better antennas. Or filters.

I prefer the antenna way… Even if your modems are broken, antennas will always be there. Check diamond sr antennas

I reset the settings to the default all except net id (left at 200 just in case) and num channels (left at 50, was 20 by default). Tomorrow I will go to another field to test it with android tower (my phone) and if that doesn’t work, I will grab my laptop to the field and run it with the mission planner for a few minutes. In today’s flight, I was at the beach, very far from any antennas, I don’t know what interference could be there!

No! let the channels as is, or even better lower them.

433 don’t have room for enough bandwidth at narrow channels

So, to what set it? 20 15, or less?

Oh, and another thing that I think it’s wrong! The min freq is actually higher than max freq, is that normal?


I don’t think so!

Also when I changed this setting on both, it stopped connecting; after changing it back on both using a usb cable, it works fine! What’s the deal with that? @Dimitris_Stefanakis

Leave everything at default which will help you identify the issue.

Upsidedown freqs is definitely wrong.

1 Like

So resetting the settings isn’t changing frequencies, can you connect your telemetry (if you have one 433 mhz) and tell me what the frequencies should actually be? Because I can’t find a screenshot online with 433 telemetries.