V4.3.2 Simulation can't run - IMMEDIATELY disarms

I’ve been playing around with Mission Planner (up til now, I’ve been manually flying all my survey flights, and I thought I’d step up my game a bit).

For the life of me I CANNOT get it to run a simulation.

I tell it “quad,” I pick “multirotor” it passes me over to the planning part, and I load up my plan, and then wait for the whole GPS lock dealie to finish (which is fun since this is a simulation) and then I shift it over to “stabilize mode.” (I know you can’t arm it in auto.)

Then I arm the virtual drone… drumroll… wait - there’s no time for a drumroll, it IMMEDIATELY disarms the virtual drone again.

Anyone know what’s going on? Thanks!

EDIT: I should also mention that the Messages tab shows nothing other than “Armed” and one second later “Disarmed.”

It needs a throttle up command, or it will disarm. You CAN arm in auto mode if you change a couple of parameters.


Thanks! Though I’m no seeing how to program in a “Throttle up” command. Is it in the planner tab? If so, I’m not seeing it. There’s a couple commands that seems like they might be related but nothing looks exactly like what I’m looking for.


Like, I see that I can change the auto options, so that I don’t have to up throttle the thing on a PC with no remote controller, but I’m wondering if that’ll affect missions once I load them into an actual drone. I’d rather not have a 12-pound piece of equipment whizzing off erratically (though I fully intend the first few times to do short missions and have it on a tether.)

ADDENDUM2: Nope. Still just IMMEDIATELY disarms:

You need to give it a takeoff command and enable the option to arm in auto without throttling up (or connect a joystick).

You do not have to keep the takeoff command or the throttle option on your actual craft if you desire different takeoff behavior in reality.

I’ve done both of those things. Takeoff command is the first one in the mission plan. I’ve set auto arm to 3.
No dice. It just immediately disarms.

If I force the issue with things like “resume mission” I get something truly weird.

That’s NOT my user directory. I’ve never heard of a “mich1” in fact.

Pretty sure there is a bug with “resume mission.” You are not the first to report that behavior. I think “mich1” is Michael, the Mission Planner lead dev.

Have you specified an altitude for the takeoff command? And have you actually “sent” the mission to the simulated Copter?

Also, you are in stabilize mode in that screenshot. You must be in AUTO at arming time.

Yup. And Yup. 100 altitute, and a simple out, back, and land. Nothing fancy. I’ve tried “write” AND “write fast.”

I hit the ARM button and it IMMEDIATELY goes back to disarmed. No preamble. No error, no nothin’.

Also, apologies. Yes. When I took the screen shot I was trying out other modes to see if maybe that wasn’t the case but yes, I was doing it in AUTO.

And I can’t stress enough that it’s IMMEDIATE.

It just goes: Disarmed->ARMED->Disarmed.

Sounds like a failsafe. But I can’t see the problem given the info at hand.

1 Like

Steps in order:
-Open Mission Planner
-Go to Simulation tab
-Select Model (quad)
-Click on Multirotor
-Choose “Stable”
-Go to Planner
-Load plan
-Write plan
-Go to Actions tab
-Make sure it’s on Auto
Immediately disarms and removes my plan from the screen.

Just select the Multirotor Icon. Simulation runs from default settings. Arm from Stabilize or Loiter, switch to Auto and then Do Action>Mission Start.

Or you can go into the configuration for the simulated copter and set AUTO_OPTIONS,3

1 Like

Does not work. Immediately disarms.

I appreciate it but I already did that, unfortunately.

I’ve also tried arming it from “Stabilize” mode.

Then hit the Reset to Default button in the Full Parameters List and try again. Really, the default settings will run in the Simulator with zero changes.

1 Like

Nope. Won’t even stay armed long enough to get the mouse over to the mission start button. I reloaded the defaults, but really other than the allow arm on auto one, all the parameters WERE the defaults. I just installed the software yesterday and I RE-installed in a few hours ago.


OKAY! I figured it out!
Takeoff doesn’t work in the mission plan.

I have to arm it, right click on the map REALLY, REALLY FAST, hit “Takeoff” and then, while it’s ascending, load the plan screen, write the plan, and start the mission.

Sure it does, I use it all the time.


Here’s how I do it (With AUTO_OPTIONS,3):

Plan the mission, with the first command being takeoff.
Start the simulator.
Write the mission plan to the simulated drone.
On the data page, set Auto Mode.
Watch the show.

No really really fast required. Question: You haven’t turned up the sim speed have you? I think DISARM_DELAY defaults to 60 on the sim, so you should have lots of time.

1 Like