V Tail quadcopter

Hi, I’m new to ArduPilot. Just installed a Pixhawk on this V Tail quadcopter (link below) and when choosing the frame type in Mission Planner’s initial setup I chose “V” as the type. I was wondering if I should use the “V Tail” option that’s next to the “V” option instead. But when I tried clicking on the circle to select the “V Tail” option nothing happens i.e, I can’t select that frame type (anyone know why I can’t?). I haven’t had my first flight yet, thought I’d check on this first. Any help would be appreciated.

1 Like

Thanks Dave, that solved my problem!