Servers by jDrones

Using wifi in station mode for Skyviper

I am trying to use the wifi in station mode as mentioned in the last part of this page: http://ardupilot.org/dev/docs/skyviper.html

I have followed the given instructions and put the required WIFI.TXT file in the SD card onboard my skyviper drone. And also connected my desktop to the access point. How can I now connect to skyviper? What exactly is the fcu_url that I must pass to mavros to connect to the drone? And what address will open the html interface to check the status of the drone?

Once it has successfully connected to your WiFI Access Point, I recommend looking at your Router to see what IP address it assigned to the SkyViper. Once you know the IP address, just type it into your browser and the APWeb should pop up. It’ll be the same IP address for anything you want to connect to it.

Thanks for the response. Due to some reason I don’t see skyviper as one of the clients of my router, although it shows the other computers connected to it. Can you tell me why this may be happening?

I can only postulate that something in your WIFI.TXT (<- Case-sensitive) isn’t correct. Also, all the data inside the file is case sensitive as well. It should just work.

Okay let me retry. I think I had everything set correctly.

Doesn’t work! I have one doubt. Do I need to create a root folder to put this WIFI.TXT file or I should just place it in the SD card without creating any folder?

It is supposed to be on the ROOT of the card. no folders needed. Unfortunately, I’m not sure how i could help more. The only way to debug it is to be connected to it (unless you wire up a serial debugger to it). I saw another thread that said they had to change routers or router settings. You might look there or ask that person.

This person got it working

This person didn’t confirm they got it working

However, Tridge and OlivierB have both done this because they showed it at some drone show 2 years ago. Also, make sure you have the latest SV firmware for the Sonix. One of the threads stated they fixed wifi station mode at some point.

1 Like

Thanks again. I am gonna read these threads and find out if I can make it work.

I tried the points mentioned in the threads and I could not make it work. Then I just thought to use my mobile phone’s hotspot instead of the wifi router and on doing so, it started working. The drone was able to connect to the access point created by my phone. I believe there is something in my TP-Link Archer C1200 Router which is making this impossible.

Yes it could be some setting on the router

Yes now it is more or less confirmed. I used a different router and it works.

Can you share what router you ended up using? I’m having my own battle against routers at the moment…thanks! :slight_smile:

Servers by jDrones