Using dshot while having a parachute on Servo_9

I just ordered some new esc’s and motors. I’ve been running the same esc’s and motors since my apm 2.6 days :grin:. I believe I had a desync issue the other day, quad fell from m 300’ but the Pixhawk did exactly what it was supposed to and deployed the parachute and my quad is still alive. So my new esc’s have the dshot capablitlity running blheli-32. I understand you cannot use the standard pwm ports and you.must use the aux out ports. But my question is this, I have my chute enabled on servo_9 . The copter website says the escs need to be in aul ports (servo_9 through servo_12). The website also says if more than four ports are needed you can set it to 6 ports. Can I leave my chute on servo_9 and start my four motors on servo_10 and set to 6?

Yes as long as you set the servo outs to the correct motor outs. The wiki is just an example of how to set up the outs, but you can set them as you need.

You’ll have to check timers, because you can’t have dshot and regular pwm on two outputs sharing the same timer.
I’m sorry right now for being a lazy person and not dwelling more into it, since my favourite copter sports BH_32 ESCs since long, and going dshot is in the roadmap, but right now I’m driving them with classic pwm signal and just enjoying efficiency increase over the older 8-bit SimonK units they replaced.

I tried using the dshot of the esc’s and he parachute and could never get the servo to respond. So I changed it back to pwm. I myself also have been running the simonk esc’s for well over 5 years and couldn’t believe the difference in performance and sound when I fired up the blheli. I run dshot on my miniquad . Everyone doesn’t know how good they have it with all the tech out there now

Try remapping the SERVOx_FUNCTION parameters. SERVO1_F thru SERVO8_F should be 59 to 66 and SERVO9_F thru SERVO12_F 33 to 36. Then plug the parachute into the former Motor 1 Main Output and test it.

1 Like

Right now all my 1-8 are 0 for none. The ardupilot instructions suggested it. I don’t think there’s even an option (27) for a chute on servo 1-8