Upgraded to ELRS, drone movements now delayed and jerky

Running Ardupilot 4.1 on Flight Controller.

The drone was working pretty well with the previous receiver, an FrSky XM+. Flying was smooth and responsive (was able to perform a successful autotune process).

I upgraded the rx to an elrs module and after a few teething problems I was able to lift off. But it feels like I have a half second delay between stick input and the drone responding. Drone movements also appear to be very jerky. I’m running a 150Hz packet rate on the elrs system if that is important. The drone even takes longer than it previously did to sound the buzzer when arming.

I’ll perform a radio recalibration and hope this fixes it. But will be interested to hear if anyone else experienced this and what they did to remedy it, along with anything else I should be doing to my setup when changing radio system.


I’m going to update this myself in case others are wondering.

No, I haven’t fixed this issue yet.

I did originally notice that a wire which powers some LEDs was running RIGHT next to my elrs receiver, so I removed in the hope the LEDs were causing interference. Nope, still the same.

So I updated the packet speed of the system to 250Hz. That make no difference either.

I did notice that within the LUA script the switch type was set to ‘ERR’. Wondering if that was the problem I changed it to Hybrid. That also appears to have made no difference, but I need to check the radio setup in Mission Planner to see if anything has changed.

I was able to fix this.

RX/TX3 on the Kakute flight controller, while being suitable for my previous FrSky receiver, is not suitable for the ELRS receiver. It took a lot of experimentation, mainly because none of the UARTS have the same number on the controller and within Ardupilot. rxtx3 is SERIAL4, rxtx4 is SERIAL3, rxtx6 is SERIAL1.

Once I had that sorted out, I wired the ELRS receiver to rxtx6, set up SERIAL1 in Ardupilot (Protocol - RCIN) and all’s good.

I have the same issue (I input any command that is roll, pitch, throttle, etc. and drone reaction have a 2 or 4 seconds delay to react or do what it should do) but I am using different hardware. I have PoweBoxSystem Radio controller “CORE” and I am also using a receiver from PowerBoxSystems. I have the receiver connected via FastTrack/Data.

IMP NOTE! I was flying with this setup normally but I had to change the receiver as it does not belong to me. So I bought the same receiver to make sure that everything work smoothly but when I tried to fly it was so scary as the reaction of the drone was delayed.

I have already calibrated again the RC Controller through mission planner; however, this did not solve the issue.

Do you have any suggestions?
Thank you.