Unwanted yaw drift, caused crash, failed EKF velocity [ RESOLVED ]

Today we’ve test pixhawk v4 on S900 frame. Yaw angle is drift so large when get 3D fix and EKF. At last time we try hard, when i could not regain control i had processed Disarm, instead of stopping motors it was suddenly increase throttle and spin, the EKF velocity got serious error then crash. After test flight today, we have broken 6 propellers. Please help me to analysis log files. Thank you.
Logging files:
2019-09-24 17-09-20.tlog (586.9 KB)
2019-09-24 17-13-17.log (521.1 KB)
2019-09-24 17-13-17.bin (264 KB)
Large logging files: (These log files will should how drone had done crazy spin)

The first thing you have to get right are the vibrations, which are pretty too high. Please Send a photo how you mounted the FC. With those vibrations it is quite difficult to get a stable flight.
Please read here: http://ardupilot.org/copter/docs/common-measuring-vibration.html

Here is the image, right on the top plate of S900 frame. Can you take a look, thank you.

I have done 2 before F450 and even on DIY frame, it had done great until moving frome DIY frame to S900 frame. I also have notice that measured yaw angle after 3D fix, internal compass and external compass measured EKF data are uncertainty.

As @Harald pointed out you have a bad vibration problem with excessive clipping.

What is odd is that these are appearing as distinct events.

You can see here that vibrations coincide with motors 6 & 3 not performing well enough so motors 4 & 5 are shutting down to compensate.

The FC is trying to compensate but the frame is just not responding

You are running a much bigger frame but with the default PID settings.
I would suggest you examine your frame for loose or twisted components and read the wiki page on tuning here

@mboland Thanks for your analysis, but i think those vibe and motor’s compensation were happen when it crash into wall. Do you know the reason what make Yaw and Ground Vel drift when GPS have 3D Fix ? Yaw is already wrong so when took off, it spin crazy and crash.
i also aware about PID parameters too, actually firmware is modified with our firmware w/ out auto tune PID. May be i should restart it to original state instead.

Hi, mounting and damping seems to be Ok from my point of view. Does your GPS point in the same direction then the FC

@Harald Yes we have checked it, if not error compass not alignment will appear. I have tried restore original firmware and it seems yaw is more stable now. But after we changed all broken propellers by original DJI props for flight test yesterday, but we found out that the vibration at each arm has appeared when throttle input above 1400 ( near hover throttle ). Do you have any idea about this ? thanks

Do you also have vibrations on your arms if you put a servo signal generator directly on the esc?

I have the same configuration on my s900 but I have no issues with vibrations


Yes, i did the same thing connect ESC’s servo signals (on S900 frame) to I/Os port to control motor. I have also double checked motors layout configuration of Hexa X frame. About the vibration, it has been solved , i was carelessness when screw to change new props. Could you share your PID parameters ? Thank you for helping me.

Do you mean you have the signal and ground connected?

Yes, of course . I connect to px4 power distribution board

Dear @mboland and @Harald ! Thanks for your help, we did it. Hover about 15min with 50% battery, no extra payload.

Would you mind telling the community exactly how you fixed it, so anyone finding this thread with the same problem will have your solution to try.


  • Place GPS module far away from Power Distribution Unit and Motors. Better put it on a stick for GPS module.
  • Check GPS by using Motor/GPS in Initial Menu (GCS).
  • Do not use modified firmware if you’re not so sure or you could lose 4-5 pairs of propeller.
  • Re-up original firmware if yaw data is unstable.