Unwanted very high / max throttle


I’m controlling my pix4 using RaspberryPI and python code (DroneKit). I’ve been using the code for a while with no major issues. My code basically switch into guided_noGPS mode then set throttle to 0.6 (takes off) until it reach 1.5 meters than I set the throttle to 0.5, change the roll a little bit than land.

Yesterday, I run this script and once it connected to the PIX the drone got full power into the engines (high throttle) and flew to the sky until I got manual control and landed it.

I tried a few more times and it went back to normal behavior but then once again, after connection to the PIX the drone got very high throttle, it hit something and crashed.

Any idea what can cause the throttle to (sometimes) be so high even if I sent it 0.6?

Not sure if related, but A few days ago I had an electrical short in the drone when I accidently connected the “+” and the “–” of the ESC power connection split board. but it looked like the drone was flying fine manually (in stabilize mode).

log file can be found here.

ArduCopter 3.6.11
Mode: Guided_NoGPS
ESC’s are clibrated