Unresponsive Throttle in Loiter

Here is the problem I face in Loiter mode:
Occasionally the copter becomes unresponsive to the throttle input and I can hear the motors pulsing every few seconds while keeping the altitude which sounds really irritating and it feels as if it is going to crash immediately!!!
00000171.BIN (653.9 KB)
Do you have any idea how I can solve this?
By the term unresponsive, I mean the copter does not respond linearly to the throttle input.
Some times it drops sharply even when I pull the throttle stick fully upward…

Ok the problem of pulsing motors solved by increasing INS_ACCEL_FILTER to 30.Now loiter works fine, but pixhawk does not disarm the vehicle anymore when I switch to land mode.Any suggestions?
Maybe I’m taking a portion of vibrations into account by increasing the filter’s cut-off frequency?

please send log file of this flight

Unfortunately, I don’t have access to my copter right now.I’m going to post the log of this flight later.

Is it a good idea to set PILOT_THR_BHV to 4 (Disarm on land detection) by default this parameter is 0 (None).I guess copter relies on DISARM_DELAY If PILOT_THR_BHV is not set.
Am I right?

With PILOT_THR_BHV = 0 copter will disarm when you put throttle stick to low position
Also check GND_EFFECT_COMP it must be 1 to detect ground effect while landing

And i was have this problem my problem was high z vibration (between 20 to 35)
High z vibration will affect EKF altitude measurements