Unicore UM982 Moving baseline issue

I’m faced with strange thing
I have several Pix32 V6 from Holybro and Unicore UM982 2 antenna GNSS recievers.
Till now i used 4.5 Ardurover firmware configured to use Unicore as a heading device. Everithing worked fine till today. I made another boat 100% the same with previous, uppload the same firmware, using Mission Planer, apply the same configuration file.
But result wasn’t the same - My boat wasn’t able to get heading from GNSS.
There is no “Unicore moving baseline” option in MP. I also tryed 4.4 Firmware - the same.
Somethind changed in Unicore support or there is some changes in settings?
I also tryed to create custom firmware, where NMEA Unicore support is enabled. No changes in MP - no Unicore option.
Here is a link to the folder with my firmware, build log and parameters file

1 Like

I have a same issue with UM982. With 4.4.4 firmware, GPS_TYPE does not show Unicore Moving Baseline (25). It only shows up to GPS_TYPE=23.

OP, Have you solved this problem? I am considering updating the firmware to 4.5, but that does not seem to help according to your post.

Hi, Kim!
No, i didn’t solve yet. ((

Seems I solved the problem. New 4.5.0 oficial firmware is working with UM982!