Servers by jDrones

Unexplained lift off while landing, with throttle held down

This morning I did a maiden flight of my latest Y6 build. It has a Cube Orange running Copter 4.0.7 & a Here2.

At the end of the final flight, I landed the copter in loiter mode & immediately began holding the left stick (mode 2 radio) fully down & to the left to disarm. However instead of the motors dropping to their idle speed & then disarming, they remained at a heightened speed. About 4 seconds later, still with the left stick held fully down & left, the motors sped up & the copter lifted off the ground & rotated slightly to the left (presumably because I was holding left rudder). A fraction of a second later the copter seemed to come to its senses, landed again & this time the motors did drop to their idle speed & disarmed.

I had a GoPro attached to the copter at the time, so here is the video evidence -

I have uploaded the log file here (the incident happens at the very end) -
https://drive.google.com/file/d/1ZmlhJ3WkeYOXocUpt3IMexRt5yUjl6GN/view?usp=sharing

I have looked at the logs & RC3 (throttle) does spike high at that time. My radio setup is a FrSky Taranis X-Lite Pro with a R9M Lite Pro module connecting to a R9MM receiver over 868MHz. All radio firmwares are up to date & I have never encountered (or heard of anybody else encountering) false channel values with this setup before. I recalibrated the radio when I arrived home & the max/min/trim values did not change at all.

The other potentially pertinent piece of information is that I was struggling with bad compass variance between the Cube compass & the Here2 compass the whole time. I recalibrated several times while in the field, but could not solve the issue. Since arriving home I think I have potentially solved it by changing the Here2 to number 1 priority - at least the calibration then completed much faster & with healthier values.

Does anybody have any thoughts? This was quite a scary encounter, because the copter throttled up & lifted off while I had the throttle stick firmly held to zero.

im not sure but for some reason the copter thought it was flying and would not disarm and tried to give it extra thrust,the reason for that I dont no,but maybe Dave or Andy can help you,for safety as I dont like the left/right arming method why not set one of the parametrs in extended tuning to arm and disarm on a switch,just my to cents so many set up varibles but least your new baby is flying and in one piece

Soft landing… I had such behaviour when installing a damper between Landing gear and Main frame.

I just had a look at my latest flight with the same AccZ value as yours (-15), so maybe another cause?

I fixed the compass variance issue & had another flight, exactly the same thing happened when landing in loiter. I also experimented with stabilize mode & it also seems to happen in stabilize.

New video & log file

https://drive.google.com/file/d/1o4rJB_W1CXX8cGW106PJh925OkJtBNb1/view?usp=sharing

I’ve been using Ardupilot for years & didn’t even know that was an option… it’s what I’ve been happily using on Cleanflight/Betaflight since I started way back in 2016! I will definitely look into that.

Are you saying that if you land too softly, the autopilot can’t detect that you’ve landed & then interprets the left stick as an actual yaw command thinking it’s still in the air? I can see the logic there & would explain why the motors don’t drop to their idle speed once the copter has landed - you also don’t hear my radio say ‘landing complete’ in the failed landing in this new video.

However in the second part of this video where I experiment with stabilize mode on the ground, I didn’t think Copter would apply that sort of yaw when the throttle is zero? I thought you always had to raise the throttle to get any attitude control? And you can hear my radio say ‘landing complete’ just before the throttle leaps up.

It looks like I’m not the first to have this issue, although these examples are from quite a long time ago. I think disarming on a switch is probably the best solution, assuming that lets me completely override the ‘landing detection’? A copter isn’t safe if I can’t reliably disarm it.

You’ve got some vibrations/clipping going on there, that will most likely be the cause

None of that clipping coincides with the failed landing though? If you look at VibeX/Y/Z you can clearly see that there is very low vibration & no clipping at all once the copter has landed, yet it then throttles up & flips after a few seconds.

Also this is only IMU3, which I understand is the non vibration isolated IMU & is used for reference/backup?

Are you saying that if you land too softly, the autopilot can’t detect that you’ve landed & then interprets the left stick as an actual yaw command thinking it’s still in the air?

I had this happen with longer landing legs. I ended up using more rigid legs and now when it lands its less physically able to yaw. When it was able to flex twist slightly it got inertia and more easily yawed on landing . I also increased the landing speed so it sets down faster. The prop wash affecting the barometer seemed to make the multirotor want to bounce on landing. I set the landing speed at 70cm/s and it plants itself better. Getting through that final landing stretch it seems like the quicker you get through it the less chance for things to go wrong, well up until you land so hard it breaks something :wink: This was before ground comp back on copter 3.3/3.4 when I had this issue. Landing on a slightly uneven surface caused it to yaw also, as it was pivoting on its 1 downed leg with the motor thrust wanting to keep it level.

Don’t try to land manually when the autopilot is in Loiter or Altitude Hold.

Either switch to Stabilize and land manually, or switch to Land.

The points are, when the autopilot is in Loiter or Altitude Hold there is a dead band around throttle. Second as the aircraft is descending it will enter ground effect that produces and ‘artificial’ lift which can and often does make landing “exciting”.

Two golden rules:

  1. Take off smartly.
  2. Land smartly.

#1 prevents ground resonance from swamping the autopilot which can cause the aircraft to flip on take off.

#2 prevents ground effect induced “ballooning.”

2 Likes
Servers by jDrones