Unable to use full throttle range

I can’t get rid of a dead zone at the top of my throttle range.
I tried decreasing mot_spin_max, and it made the motors spin slower, but had the same dead zone.
I tried adjusting the mot_thst_expo and it didn’t make a difference (It did change things, but the dead zone was still there).
My mot pwm min/max are 1000-2000. The min/max in the blheli configurator is the same. My transmitter is definitely outputting about 1000-2000.
Nothing seems to make any difference… Changing my transmitter to transmit 1800 as its max, while leaving arducopter configured with 2000 as the max does fix the issue, but isn’t correct.

Can anyone help me figure this out?
I’ll post a log and a graph…

MotMinMax.bin (116.3 KB)


Correct me if I’m wrong, but if your motors are maxed out then there will be no room for stabilization and yaw control (MOT_YAW_HEADROOM default is 200mS)

But I would expect it to still use the full range of the transmitter sticks… so in the background it would only output 1800, at full 2000 input from the transmitter… Well, that is what it’s doing… But what I mean is instead of a hard cutoff, it would adjust the entire throttle range so at 1800 input, it’s outputting say, 1600, and at 2000 input it outputs 1800. So it’s still a smooth slope on the sticks.
Basically, I’d expect the FC to do what I can do manually in my transmitter and make 1800 be what it outputs when I put my throttle all the way up while maintaining an even throttle response, instead of chopping off the top and leaving the top 1/4 of my stick throw useless.
Maybe it doesn’t though…

I’d imagine what I’m saying would be a desired behavior… And is what other flight control software does… Betaflight/DJI, etc don’t have a user noticeable dead zone at the top of the throttle range, for the sake of yaw or any other settings.

What about setting your throttle stick to output 1000-1800, but keep the range in the FC at 1000-2000. Maybe you have to play the middle position as well.
However, in non stab/acro modes, you will loose the upper range for ascend speed control…

Yes, I tried that and it does perform as expected, other than the throttle mid-point. But like you say, I could get that sorted.
I guess I’ll get a throttle curve set up to do this in my transmitter, and it’s simple to switch between different curves if I want to go back to the linear 1000-2000 for auto modes.

I still don’t completely believe this is by design, and maybe I’ve got something configured incorrectly… I haven’t seen anyone else mention this behavior, and more people are playing w/ small ‘racer’ copters these days where it’s pretty obvious… My usable throttle range above hover is only about 1/4 or 1/3 throw of the stick. That’s 87% of my power (I hover at 13%) in ~30% of my throttle stick range. Makes high speed maneuvering pretty touchy.

How about giving us a detailed list of what frame and parts you are using.

Have you read this? http://ardupilot.org/copter/docs/set-motor-range.html?highlight=throttle%20range