Servers by jDrones

Unable to prearm because of compass calibration failures

(Peter Weichhart) #1

I think I tried nearly everything what I could found in this forum:
I deactivated compass 2 (no result)
I deactivated compass 3 (no result)
I deactivated compass 2+3 (no results)
I calibrated in both methods: Live and onboard calibration (both successful)

Because of my frustrations I set ARMING_CHECK to Value 15866 all checks but excluding compass)

But I haven’t expected the result: Now I don’t get a message anymore “Compass Calibration” at Fright Data, but the behavior of the flight controller is still the same: It blinks green, beep every +/- 2 seconds (for hours) and still no arming.

I wonder if I do something wrong, or misunderstand something or is there a bug?

I hope somebody can help! Thanks a lot and greetings from Namibia

(OldGazer) #2

Go back to the beginning and give us a DETAILED description of what error(s) you are getting, when it/they started, and what you have tried to resolve those issues.

(Peter Weichhart) #3

I not really understand for which further DETAILED description you are looking for? But I will try my best to make it more detailed:

I am having a DodecaCox.

All is setup as required. Now comes the step to start (arm) the copter.
So…, I power the copter (as per SOP)
All is as expected and I get the message: prearm - Hardware Safety

  • I press the safety switch and the message is gone
  • I prearm (throttle low, yaw right)
  • I can hear the confirming “piep” and the LED’s on the HERE2 are flashing green
  • From now on I am getting the message: “Compass Calibration” (for hours)

I made a new compass calibration “live” (which was successful)
I made the same procedure as above with the same results: I am still getting the message: “Compass Calibration” (for hours)

I made another new compass calibration “onboard” (which was successful as well)
I made the same procedure as above with the same results: I am still getting the message: “Compass Calibration” (for hours)

I went through all forum threads in regards of this issue and followed all advises I could found.

Therefore I followed an advice to set ARMING_CHECK to Value 15866 all checks but excluding compass. (because it seems like that the compass calibration is a common problem)

And again…, I power the copter
All is again as expected and I get the message: prearm - Hardware Safety

  • I again press the safety switch and the message is gone
  • I again prearm (throttle low, yaw right)
  • Now I can hear again the confirming “piep” and the LED’s on the HERE2 are flashing green
    But still I am getting the message: “Compass Calibration” (for ever)

I wonder: If I deactivate the prearm check “compass”, why it is still a condition for the flight computer to arm?

I hope I got to the point!?

Otherwise please let me know

(Amilcar Lucas) #4

Please refuse any advise that tells you to set the pre-arm check to something else than 1.
make sure you save the calibration results after the calibration is completed. And please reeboot after that.
And keep the copter away from metal or magnetic sources.

(Peter Weichhart) #5

I will follow your advice and will keep trying. Thank you so much for now. I will post my results after further testing! But I am a bit afraid that I will not get any other results. I have taken a week leave, just to get the motors running. Tomorrow is the last day. With other words I was calibrating, testing, re-calibrating, testing, reading in the forum, changing settings, testing again and again now for more than 60hours…

(Siqin Meng) #6

Is the beep coming from the motors or the buzzer? If it’s from the motors, then it likely means that the ESCs are not getting throttle signal input. Is there a chance that the signal wires went into wrong ports/directions?

(OldGazer) #7

If you are getting a “Compass Calibration Requires Reboot” message you MUST disconnect the battery and/or the USB and then reconnect the battery. Pixhawk will reboot. DO NOT CALIBRATE THE COMPASS AGAIN.

(OldGazer) #8

Oh, and when I say DETAILED I mean tell us EVERY STEP of every procedure you perform, including what indications you expected and which indications, prompts, warnings and error messages you actually received.

(Peter Weichhart) #9

I like to push this issue up: I tried it many times but I have still the same issue: Compass Calibration pass (100% in default mode) but if I try to arm it comes the message "Compass Calibration in…)
I updated to the latest version, but still experience the same proplem

(curt carroll) #10

Chibios ot nuttx?
I had this same issue with Nuttx.

(Shawn) #11

I’d say set LOG_DISARMED 1 and power up, go through the usual motions then add the .bin log file here via some file sharing service like Dropbox or Google Drive, and we’ll go from there

(Peter Weichhart) #12

I strongly believe Chibios, but I will make sure. Thanks

(Peter Weichhart) #13

Seems like the problem is solved. I pre-armed with throttle up, because the green bars (MP RC Setup Page) haven’t shown my reverse of the throttle. So I was under the impression that the reverse function is not working. That’s why I pre-armed by watching the green bars.

I also reported it on another post: preArm: compass calibration running forever when i try to arm the drone