preArm: compass calibration running forever when i try to arm the drone

Hi, i am using Arducopter 3.6.9. I calibrated the compass, it shows healthy (green)

when i try to arm the drone it starts to give this error “PreArm: Compass calibration running” and this goes forever, never stops. I am thinking it is some bug in the firmware, any idea?

You must reboot after doing a compass calibration.

Unless you radically change the way your vehicle works, you don’t need to
recalibrate your compass.

I did reboot after compass calibration. compass looks fine. BUT when i press " arm", starts to give this error

Here is te log, when i try to arm, i am still getting " compass calibration running message"

Any help appreciated

Hi, @tridge maybe you have any idea about the problem i am having?

I am having exactly the same issue! I downgraded to3.6.6 and still the same. I made the compass calibration (in 3.6.6) with all 3 compass (successfully) but same issue! I made another compass Calibration (only compass 1 and 2)/ Same issue

I think is just a problem with your RC.
The patern to arm is 2 sticks down and left stick at right and right stick at left.
The patern to start compass Calibration is 2 stick UP and left stick at right and right stick at left.
If the way of your throttle was inverted you probably start calibration…
To very that, connect mission planner and controle that your throttle and pitch was in good way.
Like that.
You can try with mission planner without propeller and arm with mission planner command.
Control if command without propoller is correct.
Helper drone.


I can only test it in the evening, but I am 99.9% sure that you are right!
Because I used the reverse function for throttle and checked the reverse functions with the green bars (MP RC Setting Page). Now I learned from another post, that the green Bars are not always showing the reverse.

I was under the impression that the reverse function is not working because the green bars haven’t changed. So I armed with “putting the throttle up” (on the green bar: down). That’s why it started the compass calibration instead of arming process.

1 Like

Helper Drone: You are a super star! It it is solved because of your advise. Thank you so much!


Thanks, happy to help you :slight_smile:
Kind regards