Servers by jDrones

Unable to perform COMPASSMOT on revo-mini


(Pete) #1

Hi all,

I have been having EKF fail safes due to compass issuers when flying, the plan was to add a current sensor and do a compass mot calibration to try and resolve the interference.

Tried with mission planner and Q Ground control and would just get a ‘Failed’ message. I have just tried using the MavProxy and the compassmot command.

It returns this:


APM: Starting calibration
APM: Current
RCOutput: Failed to set PWM frequency req F set 3F

RCOutput: Failed to set PWM frequency req F set 3F

APM: Failed
Compass

enabled

Mag Dec: 0.0000

Mag0 off: 280.0825, -388.2040, 282.6600

Motor Comp: Off


Other wise Quad is working fine, Any ideas?

Thanks


(Pete) #2

Created issue for this problem:


(Giorgio Rinolfi) #3

I wonder if during the betatesting are people performing COMPASSMOT for checking it.
Because its from 3.6 that I have the same “failed” massage in MP with a Pixracer, but I don’t know if its my fault and I was waiting to hear something similar the above.
Please could you report that compassmot are performing normally with the last beta?
Thanks


(Pete) #4

Could be a wider issue, I assumed it was just the revo-mini, please post your hardware and firmware versions in the latest release candidate thread and on the github issue.

I find mavproxy gives a more informative error message then MP.

Thanks


(Giorgio Rinolfi) #5

I have Pixracer and I’ve try with 3.6 rc1/rc2/rc3

I’ve just tried now again but I’ve made some heavy modifications to the firmware and it cannot start at all. Could be really usefull if someone could try it and report back if its working ok or not, its just to click a button in MP and check if the procedure its starting, nothing more.


Copter-3.6.0-rc6 available for beta testing