Unable to do compass calibration. Failed to initialize MAVFTP and no response from MAV

Hi! I am trying to do the compass calibration of my px4 with black cube, but I can´t. I assume it is because there is the error message “failed to initialize MAVFTP” when I connect with mission planner. When I try to arm the vehicle, I get the error “no response from MAV” and also when I go to compass, sometimes I got the error in the image. I can´t find anything online to solve this problem and I am not sure why I can´t do the calibration anymore as it was working some time ago. Just in case I have downloaded the latest version of mission planner and plane firmware. I have also tried to connect through to px4 externally with a telemetry antenna or connected to the computer, but still not working, so please help me!


I experienced the same thing, can anyone help?

Hi Veronica,

Did you ever find a solution to your “No response from Mav” error?

seems its custom firmware and many options activated, so it may be no enough RAM to allocate requested volumes by MAVFTP or compass calibration. Faced with this situation when using custum compiled firmware on F405