Uavionix ping2020 W/PingNav Baro ADS-B setup

I have a ping2020 W/GPS and Baro PingNav and I have not been able to get airtraffic to show up on MP, I have it on telem2 and it shows up on messages when I connect to MP W/usb or Bluetooth with call sign & ICAO info, but also there are alot of configurable options in the full parameter list that I do not know the necessary parameters. also all current firmware ArduCopter 3.6.5 & MP 1.3.62
ADSB_LIST_RADIUS 800 or 1000 or 10000

and I built my telem2 cable as 5v to 5v, Gnd to Gnd, tx to rx, rx to tx.

Please help me make this work, I have tried for days now. Please help me fill in the blanks.

This is the second report of difficulty getting the Ping2020i working with ArduPilot.

I’m starting to wonder if the Ping2020i vs Ping2020 have different default protocol behavior.

For RX purposes my understanding is that the Ping2020 should only require a MAVLINK2 modification to the standard PingRX parameters.

I have one (a Ping2020i) myself, but I suspect that I will fail to find anything that you have not . . .

Just to be clear I have the ping2020 w/ external FYXnav-B, ping2020 The original remote mount ADS-B transceiver for sUAS, not the all in one.

Oh, okay - that should have been obvious from the title, my bad.

So my testing will be a little different, but I’m hoping to get around to testing mine soon.

That said, it sounds like there is may be something going on in the background, as the instructions for setup are very simple, and there don’t seem to be any recent critical changes.

MagicRuB seems to be the latest and highest volume contributor to support for ADSB transceivers. Any comments or suggestions @MagicRuB ?

This is the first I’ve heard of any problems. However, I think they have a tool that is needed for configuration now. Please ping uavionix tech support and post their responses here.

If by tool you mean that wifi ping android app, lets you program he call sign,ICAO ect …is it this your speaking of? ping%20config
I’ll tell you something strange tho, after I program and save the config on either ping2020 or PingNav on the config app the units has the changed config information, but in mission planner in the messages tab it’s a random call sign from the ads-b but the ICAO is changed to the 696969 i set? this is odd I thought.

yeah, that’s the weird thing about their app. Instead of adding to, or creating a new, mavlink message they decided to use the upper 8 bits of ICAO as magical status bits that their app takes advantage of. That allowed backward-ish compatibility that didn’t depend on ardupilot version. I called it “encoded ICAO” in this comment I wrote here:

I don’t know where the 696969 comes from, that’s new to me.

I set the ICAO # to 696969 in the ping android app, that changed and stays constantly displayed in the MP messages tab, but the call sign I set to WT650 with the ping Android app and that is never displayed in the messages tab in mission planner or anywhere… I only see WT650 in the ping android config app, MP messages tab states a random call sign (PING564 or PING901) upon mavlink connection.

just checked the setup instructions for your ping2020i, same as mine I would be really interested to see what your results are from setup & to see if your track-able " To test the system you can compare with flights shown on []" also your MP should display nearby aircraft (

I also have these settings, I think that these are correct, to enable working ADS-B Avoidance…

AVD_ENABLE 1 0:Disabled 1:Enabled
AVD_F_ACTION 1 0:None 1:Report 2:Climb Or Descend 3:Move Horizontally 4:Move Perpendicularly in 3D 5:RTL 6:Hover
AVD_F_DIST_XY 100 meters
AVD_F_DIST_Z 100 meters
AVD_F_RCVRY 2 0:Remain in AVOID_ADSB 1:Resume previous flight mode 2:RTL 3:Resume if AUTO else Loiter
AVD_F_TIME 30 seconds
AVD_W_ACTION 1 0:None 1:Report
AVD_W_DIST_XY 300 meters
AVD_W_DIST_Z 300 meters
AVD_W_TIME 30 seconds
AVOID_ANGLE_MAX 1000 0 4500
AVOID_DIST_MAX 5 meters 3 30
AVOID_ENABLE 3 0:None 1:StopAtFence 2:UseProximitySensor 3:All
AVOID_MARGIN 2 meters 1 10

No matter what I do, I’m unable to get the air traffic to show up on mission planner as advertised, I have tried about 10+ different configurations all with the same out come, no displayed air traffic in mission planner, this defeats the purpose of having this hardware.

this was the reply from Uavionix support…
"The autopilot will always win. The customer has 2 configuration sources. The FYXnav and the autopilot. It needs to be one or the other and not both.

I would recommend setting the MP serial port to use Mavlink 1. I think that will resolve the configuration conflict.

That would be


Alternatively, they could remove the TX wire from the autopilot to the back to the ping2020 4 pin JST. This would allow them to use the 2020 as a receiver with MP and still configure via the FYXnav.”

None of this is covered in the super simple installation instructions from Uavionix, still waiting to hear back from them to clarify the needed information to make things work.

also tried the protocol change…nadda

1 Like

So I just hooked up a PixRacer I had laying around, running AP 3.9.1, and connected my Ping2020i via Telem2.

I configured baudrate = 57600, protocol = 2 (Mavlink2), ADSB_ENABLE = 1, ADSB_RF_CAPABLE = 3 (I didn’t want to broadcast right next to DAB), and ADSB_RF_SELECT = 1.

Everything else is default.

I shut off my internet to ensure MP wasn’t pulling from a server.

I can see ADSB out halfway across Florida, and occasionally one on the opposite coast.

I’ve attached my parameter file below.
Ping2020iTestParams.param (14.5 KB)

So what is the difference in my case?
So far:
TX disabled.
Using a Ping2020i with integrated GPS - No FYXnav attachment, etc.
No configuration via the app - all configs done via autopilot parameters (I just plugged in a vanilla Ping2020i straight from the bag)

I’ll be updating with pictures of connections momentarily.

Setup Image below - I have no other devices connected to the PixRacer, though I was using USB to connect with MP. The Ping 2020i is powered (currently) with a 12V adapter, for convenience sake. I used uAvionix’ stock JST-GH cable (there are several included, but only one with a JST-GH).