UAVCAN GPS Problem with Ardurover 4.2

To keep the scurves testing thread clean, I start a new thread here.
My rover has a Mateksys H743-Wing V1 with two Emlid Edge UAVCAN GNSS modules.
With Rover 4.15 the GNSS modules work as expected, with 4.2 beta1 and 4.2-dev (scurves5), Missionplanner shows “Unhealthy GPS signal”. Both GNSS modules show a fix with their green LED, but Missionplanner shows “no fix”.
Here is the parameter file:
20220305BigRover42beta.param (19.5 KB)
I am heading outside now, to see if being outside changes anything.

Here is a short log file from driving outside:

Ah ok, a 3MB file and also a 1.2MB zip of that file exceed the 4.4MB upload limit…

P.S.: Simple avoidance does not work either. Distances are displayed in Missionplanners proximity view, but the rover does not stop in front of obstacles.

I tried to make the GNSS work over the weekend, but could not find any setting that would make a difference. All parts(GNSS, baro, IMU) of the modules are present on the CANbus, all of them are recognized, baro and compass are used by ardurover, the IMU (it probably does not get used in 4.15 either, I did not check) is not and GNSS just produces the “unhealthy GPS signal” message.

I know it’s not particularly helpful to solving your problem, but in the interest of helping the community at large, I can confirm that a uBlox M8N module connected through an mRo CAN adapter had no trouble in the transition from 4.1 to 4.2.

1 Like

Thanks for your reply, Yuri.
The Emlid GNSS modules I use were part of the Emlid Edge flightcontroller package, which was discontinued after a short time. I do not use the Edge FC anymore, since it was too limited in many ways, but the GNSS modules are nice and worked flawlessly so far. If it is a problem only affecting those modules and given the limited number of people using those, I will just buy new modules and save Randy and the other devs the hassle.


We discussed this at the weekly dev call and Tridge is going to have a look. We think that maybe the new DroneCAN GPS support (for GPS-for-yaw) has only been tested on CubePilot GPSs (because that’s what the developer had) so we are going to re-test with another manufacturer’s GPSs to confirm this and then hopefully resolve it.

Thank you Randy,

as I said, if the problem only affects these specific GNSS modules, I do not know, if it is worth the effort. They are EOL and do not get any support by Emlid anymore.

Hey @count74
check this.

Are those settings only for GPS yaw, or to get UAVCan working with 4.2?


Those instructions are for gps-for-yaw. There’s no change in the more general procedure of getting DroneCAN (aka UAVCAN) working as compared to 4.1.

Indeed. And I can also confirm that I had no issues with moving baseline configuration from 4.1 to 4.2. Seamless transition for me overall in that regard.

There are significant differences in GPIO config, but that’s another topic.

1 Like