Tuning the Harmonic Notch

So, some type of Vtol. I’m don’t experience with those. But from just a Notch Filter perspective this is the only data you need to look at (Gyro only):

So I see it as centered ~136Hz with a wide bandwidth. What you set for the Dynamic Notch is working perhaps you could tweak it. I’m not sure you need the static notch.

But, your Z vibrations are off the chart with thousands of accumulated clipping events. Notch filtering is not a cure for this it has to be addressed 1st.

It has to be particularly bad for a Flight Controller with IMU isolation to be this terrible.

Yes i agree that z axis vibrations are very bad and easily reach 60 or even more while i am giving roll or pitch in qloiter or in qhover.
i am using cuav h7 pro which I believe a very good FC and has isolated IMU with dampener.
I have mounted on fighter vtol with Double-sided tape. Do I need to use a vibration dampener to reduce Z vibration?

60? Peaks >140 are seen here.

My opinion is yes of course you do. But others will say that Flight Controllers with isolated IMU’s should be “hard” mounted. Meaning with the tape supplied by the manufacturer. But before that look to reduce the source of the problem.

I intrude into this discussion, as a beginner on the subject, to ask how the FFTACC peaks are lowered … by working on the HR isolation … or you can also by inserting a filter like the one used to attenuate the FFTGYRO peaks ???

Ignore ALL FFT ACC0 graphs (on the left).
Only FFT GYR0 graphs (on the right) have important data.

i am not able to figure out the source of the problem. everything seems good and hard mounted and it is fighter vtol with stock motor and propellers. Don’t know what is causing those high peaks. I am sure z axis vibrations are due to Frame issues but can’t find what is wrong.

Accelerometer noise gets removed by the EKF filter. No need to do any further filtering. But you can and should reduce the vibrations that cause the noise in the first place.

Try posting in the Vtol thread. This isn’t really a “Tuning the Harmonic Notch” problem.

vibration noise on z axis you are talking about?

Yes, I am talking about vibrations on the Z axis and all other axis :slight_smile:

any idea what i can do. Should i try vibration dampener as again i need to do everything from start because this VTOL crashed while autotuning

It crashed because of those vibrations, if you do not fix it it will crash again. Yes, use dampeners. Test multiple.

Thanks a lot will do the changes

Hello @andyp1per

Sorry for reviving an old thread but this seemed like the best place to ask about Harmonic Notch setup questions.

I am running Copter 4.0.7 on CubeBlack and Throttle based setup. Motors are 700kv running 12 inch props on 4S battery. eClac suggests a hover RPM of 4900 (82 HZ). Here are my notch settings:


Pre-Notc & Post notch FFT graphs:

Pre Notch Log: https://drive.google.com/file/d/101SSZ8iQKAenUNtQzkv7HTDQc8VEE6yG/view?usp=sharing
Post Notch Log: https://drive.google.com/file/d/1FtjyVfXO4YGPdRPAU7fY5IFqdZylYOTK/view?usp=sharing

Magnitude of Noise went down significantly after the Notch although there is still a visible spike at 89 Hz. Is this GOOD or BAD and how can i improve on this please? Can increasing ATT from 40 to 50 make it any better and is it even recommended?

P.S there is a peak at 47 HZ in Post Notch graph Gyro-2. This was not even visible in Pre Notch due to very low magnitude compared to the 81/82 HZ peak. Does this need attention as well? And generally what is the acceptable Post Filter FFT magnitude ? Many questions but just trying to understand the whole thing so that i don’t keep bugging you again.

Thanks in advance & wonderful work btw :slight_smile:

Looks ok, there will always be some noise. I can’t answer the question about magnitude because @Michael_Oborne changed the scale :stuck_out_tongue: if you use mavfft_isb.py from pymavlink I could give you a more definitive answer

Thanks for replying. @andyp1per
Here are the FFT plots using this command “mavfft_isb.py 2.bin --scale linear --output lsd”



Ok, so anything above 1.0 is bad - easier to see with the log scale as its anything above 0. Ideally you would have stuff much lower, but I think that spike at around 50Hz is some cause for concern - you might want to try a static notch on it.

Thank you Dr. Andy :slight_smile:

On dB scale the PSD output is around -5 at 48/49 Hz. I will try adding a Static notch and see what difference does it make.

Can you please confirm if it is necessary or recommended to change ATC_RAT_RLL_FLTT & ATC_RAT_PIT_FLTT to ZERO when conducting the Autotune? And do we set it back to 15 (or whatever it was) after the autotune is successful?

I followed Tuning Process Instructions — Copter documentation and the FLTT values were set to 20 when Autotune was performed. I did not set FLTT to 0 for Autotune and the tune was pretty bad. Crashed the copter in Loiter mode when i applied pitch input. Could this be the reason for a bad tune?

Thanks for the help

If you are tuning on 4.0 you will need to set FLTT to 0 before running autotune. If you are tuning on 4.1 then this is not necessary.

I wouldn’t set AGGR to 0.2 - I think that’s a bit too high unless you have a really noisy copter. 0.15 or 0.1 is better.

Here begins a long list of I’m confused questions. Setting up a brand new frame X, 15-inch props, slightly offset in height slightly tilted forward. Am I right in thinking 142Hz is the problem child here? I am not really sure what I am looking at.