Tuning Altitude Hold in a powerful quad

Hello all,

I am working right now in an autonomous 6 inches quad that is as powerful as a racing drone. I made it to fly pretty decently, but in altitude hold I notice how the drone buzzes because of the motors accelerating and decelerating really fast all the time, trying to keep the altitude. So the drone does not sit smoothly but a little bit bumpy. That happens as well obviously in AUTO mode, and I guess in all modes that hold altitude. I went thru the wiki and I was reading that In powerful copters Throttle Accel should be decrease by 50% in both P and I to 0.5 and 1. But I realized those are the values I already have.

I wanted to decrease Altitude Hold P but looks like 1.000 is already at the minimum.

Should I keep decreasing P and I in Throttle Accel?

Thanks in advance

It may not due to an actual altitude hold issue.
There are experts with small quads (not me) but normally that pulsing motors or noisy motors is because of vibrations, incorrect gyro filter setup (and other initial parameters) and needing Harmonic Notch Filter.

Also if motors are reaching minimum output to hover then you could try reducing MOT_SPIN_MIN (and ARM) or add a bit of payload to get the motors into a workable range.

Need a .bin log file to tell more…

Thanks for your assistance.

Here you go:


Yeah, so apart from some noise or oscillating, the motors are bottomed out a lot of the time

And there’s some conflicting settings
You need to have MOT_SPIN_MIN higher than MOT_SPIN_ARM
Use the MissionPlanner motor test to set MOT_SPIN_ARM for the lowest reliable startup speed, then add a bit to get MOT_SPIN_MIN . Usually we add 0.03 but this may vary depending on use-case. You still want the motors to reliably turn in the correct direction while dealing with vertical descent.
If motors are still hitting their minimum for basic flying then add some payload even just to get it tuned properly, or put on smaller props.

Also connect to MissionPlanner and press Alt A and plug in your prop size and battery cells, check the results against your existing values. Accept all new values it offers values unless you’ve got a very special reason not to.

Also set these for your Harmonic Notch Filter, since you already have ESC telemetry working
INS_HNTCH_ENABLE,1 ← reboot after setting this one to see the rest
INS_HNTCH_FREQ,100 ← use these as a starting point till the next log is checked

We have good reference documentation for a build like yours:
THE build Blog

Thanks, I was already taking a look and I will be going thru this deeply.

What’s up with these?

Not valid values. Actually these are default value and OK. I confused 2 parameters sets.

Thanks a lot, I did some of this changes and I will start test flying.

I have a couple of doubts for a long time maybe I can make here a couple of questions:

  • Once I am satisficed and happy with the settings and calibration, If I build a second drone with identical hardware, and I write on its controller the above mentioned parameters, will I have to re calibrate the sensors (accelerometers, voltage, current) and the compass?

  • I have 2 GPS for redundancy, I have both of them enabled and with the option GPS Blend. I can see in the GCS that I have both GPS working and with 3d fix, however when I review the logs I cannot se the green line (Gps2) nor the yellow (GPS blend):

I do not remember changing these values, at least not in a voluntary way. What values should I put there?

It’s in the Tuning Guide but let’s look in the 7" Build Log:
PSC_ACCZ_P=0.14 vertical P gain at hover thrust
PSC_ACCZ_I=0.28 vertical I gain at double hover thrust

Substitute your values for the Bold ones. Default values would probably work OK.

OK thanks,

but for these 2 the default values are


SO what should I do? you said before that they are out of range

I’m sorry, I confused the 2 parameters sets. These are at default as you have them and are fine.

It’s the ACCZ P&I I was getting at.

Sorry about that!

OK thanks a lot for the help.

I did the Alt+a and got all the values, however with them the drone shakes in yaw a lot. I did not know this Alt + a feature so some time ago I went through the tuning guide and manually went in the tables and got the approximate values. With these values my copter flies better so I came back to them.

Few lines above, There is a picture of the map and a couple of quick questions that I always had, please take a look if u have a second.

When building identical craft there is a lot you can copy over, but not the mandatory calibrations.
First set up the frame type and do the calibrations.
Radio calibrations could copy over, but I would run through that process anyway just so you can see it working properly in MissionPlanner.
Voltage and current may not need recalibration, do a quick voltage measurement to see how accurate it is.
The tuning PIDs and any other settings you changed could copy over provided you are aware of their purpose. Motors, ESCs, props and just about everything would need to be the same or PIDs will need retuning.

When you save a param file it’s just text, so you can cut out all the stuff you dont want to copy over and resave the text file as some sort of standard param file for yourself. Generally just keep the minimum number of parameters you really need.
Usually these:
BRD_ *
GPS_* that you changed
INS_* that you changed, not all!
…and so on down the list, trying to just select things you needed to change

There are some read-only parameters that you cant copy over even if you wanted to, like MIS_TOTAL, RALLY_TOTAL, STAT*
If in doubt don’t copy over every random parameter.

Good question. With Blending enabled you should have GPSB and GPAB messages in the log but I don’t see them. But then I have never used blending so no direct experiance.

I tried again and now I can see everything, looks like it fixed by itself.

I understand, that was my guess but now im 100% sure.

I have realized that if I do Alt + a and use the values provided, I am getting worse results than with the values I got going manually through the charts. So I came back to my values.

I made the changes that dkmexr said:

PSC_ACCZ_P=0.14 vertical P gain at hover thrust
PSC_ACCZ_I=0.28 vertical I gain at double hover thrust

And I already noticed a way smoother behavior.

Now I have to add what you recommended and try:

INS_HNTCH_ENABLE,1 ← reboot after setting this one to see the rest
INS_HNTCH_FREQ,100 ← use these as a starting point till the next log is checked

1 Like

Hello again, today after testing more things to make the drone fly smother in Auto and Altitude Hold, I tested the drone in Throw mode the first time.

What I tried was mode 2, when you let the drone freefall. The drone detected the freefall and armed in throw mode. However as soon as the props started spinning It started rolling violently like crazy and crashed.

Fin attached the log. I do not know if this question is good here or I should open a new topic.


Thanks in advance.

You might to start a new thread with Throw Mode in the Title. I used to use Dropped Throw Mode all the time from the back deck at my house and it worked all but 1 time. Then I stopped using it…

Kind of guessing here but there is useful data in the log.

Throw Mode is detected when Stage goes from 1 to 2. It’s rolling as it’s dropping to ~30deg when the Attitude OK goes from True (vehicle upright) to False (not upright) and then I suppose it hits the ground. I’m not sure why it thought it wasn’t upright at 30 deg roll but in any case perhaps there wasn’t enough height/time to stabilize. ESC RPM was only up to ~1000.