Servers by jDrones

Tuning Advice Needed For Heavy Quadcopter

Hi.
For a couple of weeks, I have been trying to tune my heavy quadcopter.
It is equipped with KDE7208XF-135 motors, KDE 24.5 inch dual propellers, and KDE-UAS75HVC ESCs.
The takeoff weight of the quadcopter is nearly 13kg.
Lots of PID tuning wiki reads and tuning flights, I have accomplished reasonable stable flights on both manual and auto modes.
I am attaching the logs.
However, I can not be able to reduce vibrations.
Vibrations on the X and Y-axis seems to be reasonable and do not interfere with stable flight.
I am seeing peak to peak 2 meters of altitude error on auto flight modes.
I am thinking that it is related to high vibration in Z-axis.
Is this Z-axis vibration normal since it is a really big drone or should I focus to reduce them?
If so, how can I achieve that?
I did some fixing on wires and other things inside the fuselage and nothing seems that it can be moved during flight.
Can I improve Z-axis vibration and better altitude controlling?
Is it related to PSC_VELZ_P?
Thanks for all of your efforts and suggestions.
https://drive.google.com/drive/folders/1BwohvNEUg5LWb8VEvcYmYc-GQ7LBCliY?usp=sharing

Hi @Mustafa_Gokce
your tune is not too bad

but these PIDs are high for a 24inch copter

vibration on z is a bit high and could make altitude and vibration problem

you can setup harmonic notch filtering to reduce noise on gyro

after this send us a log with LOG_BITMASK = 196607 for a better analysis

good luck with tuning

1 Like

how do you measure your 2 meters hight error, thats within gps and baro error :wink:

How is that Cube mounted? As Hosein says the dynamic notch filter would likely help. Set INS_LOG_BAT_MASK to 1 and make a simple AltHold Hover flight for ~1 minute and post that log.

1 Like

Hello again @hosein_gh and @dkemxr :slightly_smiling_face:
Sorry for the late response to your suggestions.

Today I had a chance to do your suggestions regarding logging parameter settings (except notch filtering).
Could you please look at the log files below in your free time?

https://drive.google.com/drive/folders/1YWUNBF3TXlufFgtqnyoGbWURQ2PQKK81?usp=sharing

Thanks for all of your efforts…
My sincere regards…

OK you have high amount of noise on 100hz

set these parameters

  • INS_HNTCH_ENABLE = 1
  • INS_HNTCH_REF = 0.4437652
  • INS_HNTCH_FREQ = 100
  • INS_HNTCH_BW = 50
  • INS_LOG_BAT_OPT = 2

then do a 1min hover flight in althold or loiter and send log file again

2 Likes

Dear @hosein_gh.
Thank you for the suggestions…
I set the parameters according to your suggestions.
I attached the logs.
https://drive.google.com/drive/folders/1Fw3tCLQDhHWo10ozODTPBE83oiL23sH-?usp=sharing
Could you please look at them?
Thanks :slight_smile:

no FFT data in this log
did you uploaded correct log file ?
also did you set INS_HNTCH_MODE = 1 ?

1 Like

@hosein_gh, yes I can’t see it either.
Yes thats the correct log file.
I didn’t change any log parameter except INS_LOG_BAT_OPT.
I checked INS_HNTCH_MODE,1.
Should I do a flight again?
Thanks.

yes we need another hover flight with these settings

INS_LOG_BAT_MASK = 1
LOG_BITMASK‘s IMU_RAW bit must not be checked. The default value is fine
INS_HNTCH_MODE = 1
INS_HNTCH_ENABLE = 1
INS_HNTCH_REF = 0.4437652
INS_HNTCH_FREQ = 100
INS_HNTCH_BW = 50
INS_LOG_BAT_OPT = 2

1 Like

I will do the flight in a couple of hours and will send the logs to you.
Thank you so much for your interest and kind answers.
My best wishes…

1 Like

Hi, again @hosein_gh.
Sorry for the long waiting.
There was a strong wind yesterday so we canceled the flight.
Today we did 2 flights (on separate drones but the drones are identical).
I am attaching the logs.
Thanks for all of your efforts…
https://drive.google.com/drive/folders/1n8wwqk8NtewZ5wnz_PwtpsurumY1q9JQ?usp=sharing

OK now you have much less noise (its reduced from 700 and 150 to 18 and 12)


and its affected your pids

so go ahead and do another autotune again to get right PIDs

but before running autotune you need to fix your motors unbalance


CW motor are working harder, is CW arms/motors twisted ?

but a note motor unbalance happened in you second flight :point_up_2:
in fist flight it was ok :point_down:

first try to recalibrate ESCs

@hosein_gh, in these flights, did the notch filter really affected the PIDs?
I might be wrong but could the filter affect only the logged IMU data?
Because there are two parameters related to harmonic notch filter.
Those are INS_HNTCH_ENABLE and INS_NOTCH_ENABLE.
During these flights the parameter INS_HNTCH_ENABLE=1 but INS_NOTCH_ENABLE=0.
Should I change INS_NOTCH_ENABLE to 1?

I will take a closer look at the drone that corresponds to the second log.
The drone’s ESCs might be incorrectly calibrated since the arms and motor mounts on the drones are really strong and stiff.

I will do the AUTOTUNE as you suggested and post the logs.

Also, I wanted to mention that on the second flight (corresponds to the second log) I saw some small instabilities (like really small oscillations) during pitch backward. I didn’t see those oscillations during pitch forward and roll maneuvers. If I am correctly remembering, I did this 3 times and saw these oscillations only when pitch backward. There wasn’t anything like that on the first flight.

Thank you for all of the suggestions :slight_smile:

because of reducing noise on output FC will have different calculation

No its for static notch

its because of your PIDs, don’t worry it will be fixed after autotune

Good luck with tuning and let us to know how you go

2 Likes

This is for the fixed notch filter so no. Unless you want a fixed notch but all discussion to date has been for the Dynamic Notch.

Also, you should set the INS HNTCH_ATT to 40 and make another Hover flight.

1 Like

Dave is right at the first look i think it was INS_HNTCH_ENABLE
Sorry for mistake
I edited the last post

1 Like

Thank you for the suggestion.
I will do it on Monday and will send the logs immediately.
Best wishes…

You may get a message in Mission planner saying 40 is out of range for this parameter. Ignore that and make the change.

2 Likes

Hello again, @dkemxr and @hosein_gh.
Today i attempted to do the autotune process with INS HNTCH_ATT=40.
There was a strong wind but i was able to finish tuning processes on roll and pitch axes.
Could you please look at them?
I am wondering about whether it worked or not since there was wind during the process and i had to intervene the process most of the time because of the drift.
I am attaching the logs.
Thanks for all of your efforts.
Regards…
https://drive.google.com/drive/folders/1wpCSBrzkSg5Amj_RqLVwCqzDZUxQLy7F?usp=sharing

Servers by jDrones