Servers by jDrones

Tuning Advice for 13" quad

Hey everyone. I’m looking for advice on dialing in a perfect tune on this copter. It feels good in the air, but from what I can tell, the logs say it could be better. You can view the log in-browser here or download it here.
This log was a short test flight after performing an auto tune.
I have the dynamic notch dialed in with RPM filtering. The main thing I’d like to see is ATT.desroll and despitch track closer.

I’m open to any advice or ideas. Thanks!

Specs
3.3kg AUW
13" props
6s 9Ah Li-Ion
Control Zero FC

Change these since it flies OK:
ATC_THR_MIX_MAN,0.5
PSC_ACCZ_P,0.273
PSC_ACCZ_I,0.546
AUTOTUNE_AGGR,0.1
and run another Autotune.

ATC_INPUT_TC is set pretty aggressive, you might want to try 0.2 or slightly higher - for a softer “RC Feel”.

I recommend you calculate and set your BATT_CRT_VOLT and BATT_FS_* parameters.
Do a Motor/Compass calibration if you can too.

1 Like

I implemented all of your suggestions and it’s flying very nicely. Here’s the log of the autotune and subsequent test flight. The only thing I see from flying it that could improve is it drops a few feet if you make a more rapid ascent and then bring the throttle back to neutral. Do you have any suggestions on correcting that? Does anything else in the log stick out to you? I’d still like the roll and pitch to track closer but I can’t feel any difference while flying.

Download
View

That looks pretty good now. I could see what you mean in the log - the throttle channel goes up, the altitude starts going up, but when throttle is leveled the Alt goes down a bit.
image
Basically the FC thinks you’ve overshot the desired altitude.

Try these, not sure if it will help.
PILOT_SPEED_UP,300
PILOT_SPEED_DN,200
PILOT_ACCEL_Z,300
PSC_ACCZ_P,0.56
PSC_ACCZ_I,1.12

INS_ACCEL_FILTER might be able to go up a bit to 18 - experiment with this one. If it’s too low you’ll see physical oscillations in roll and pitch, if it’s too high you’ll hear it in the motors and RCout channels will show PWMs criss-crossing with a noticeable difference instead of being all about the same.

The Vcc (5 volts) is a touch on the low side, keep an eye on that.

I’d probably revisit the Notch filter settings.
I had an idea that someone said INS_NOTCH has limited value, I think especially if you’re using INS_HNTCH or for lower frequencies??? - but dont take my word for that, check it out yourself.
I think INS_HNTCH_ATT can go higher value, like 30 - that was pointed out many times to people in the Harmonic Notch Filter subject, but I need more experience with it too.
So I’d probably redo the harmonic notch filter tests and make any changes, then run another Autotune.
Normally after that we’ve only ever had to adjust some Yaw settings to suit more or less acro craft.

2 Likes

One small difference I noted - my recent builds with AC 4.0.3 and 4.0.2 have this:
PSC_ACCZ_FILT,20

Yours, AC 4.0.4dev have:
PSC_ACCZ_FLTT,0
PSC_ACCZ_FLTE,20
PSC_ACCZ_FLTD,0

I’m not sure how much difference that would make

1 Like

@andyp1per can you comment on this?

The notches are the same in terms of their effect - it’s just that one moves dynamically and can target harmonics as well. So if you are targeting a static noise peak then INS_NOTCH will work fine, but generally the noise peaks are all related to motor rpm

1 Like

In actual fact I was thinking of INS_GYRO_FILTER and these pics below illustrate what I meant. Feel free to continue to experiment with INS_ACCEL_FILTER filter though - it would be nice to hear the results if you get around to it.

INS_GYRO_FILTER too high
PWM output - Filter too high

INS_GYRO_FILTER default 20

I set INS_GYRO_FILTER to 18 and here are the results. Download

The PWM out looks pretty good to me, but I’ll let you be the judge. The only thing at this point I’d like to improve is it’s ability to hold position without an ideal GPS lock, and the fact that the motors come down pretty toasty. I’m using Brotherhobby 2812 600kv with APC 13x4.5 MR. I’m going to give the Hereflow another shot and see if it improves the position hold in poor GPS situations.

Lowering you gyro filter will make it hard for your quad to make small adjustments, for a large copter with a lot of mass it doesn’t matter, but for a small copter it’s disastrous. Make sure your DFLT and TFLT settings are comparable with your GYRO_FILT

This particular copter doesn’t like the recommended filter values for it’s size. I originally set it to 30hz which resulted in an unflyable copter. High current consumption, hot motors and really bad vibrations. As I took it back to 20 it’s fine. I’ll double check DFLT and TFLT, thanks!

Right - and too high and you will smoke motors!

1 Like

I had this same problem on a 13" quad, I ended up setting everything back to default and manually tuning it. The Rate Roll/Pitch filter settings were OK (17Hz) but gyro at 30Hz, no way. With some of the pre-tune settings the motors were being wildly commanded from low PWM to High cyclically, I could hear it.

It’s tuned pretty well now and using the FFT referenced notch filter.

1 Like

I’m thinking that to use INS_GYRO_FILTER at higher values than default (20) requires some manual tuning and generally higher PID’s than normal, specifically D term. This is going to be important for smaller frames, and less so for anything over about 13inches, which can just stick with default INS_GYRO_FILTER.
If you look at the default “Preset” values in MissionPlanner for the Hexsoon 450, the INS_GYRO_FILTER is 40 but PIDs are higher than usual for a frame that size.

I’m thinking about gathering a whole range of param files from everyone to look for trends relating PIDs to frame size (and a few other things). I’m hoping I can narrow down default values a little more and reduce first-flight instability and crashes -> then let Autotune take over.

2 Likes

I just saw your other post and I think that’s a good idea. The curve function for prop size to Gyro filter may need some tweaking. Perhaps a multi order poly function. It’s hard to know w/o a lot of data. The ATC_ACCEL_P/R values were too low on my 13" also. back at default performs better. But this may depend on the use case. It’s a 13" quad but it’s light on 6S power and it’s not carrying anything.

1 Like

Sir how it’s possible , i have been doing that and also my 2 motors are smoked and also 1 battery die , plz tell me behind this situation.

Thank you :slightly_smiling_face:

@Moksh here isn’t enough information in your post to help. Did you already create a topic about it?

@xfacta Here is the RCout of my 280mm quad with 7" blades with INS_GYRO_FLTER=60

The ‘d’ is wayy low of about .001 and the motors are cold as can be after a 15 min

I can try bringing down the gyro filter to 30 and then to 20 and see what kind of differences it makes. But as of right now if flys really well

Also here is the tracking after 2 autotunes

1 Like

Those would be good tests if you can spare the time.
Otherwise you could even check and maybe adjust AUTOTUNE_MIN_D and run Autotune again and see if D terms come up higher.

But hey, if it’s flying good now, no need for changes! :slight_smile:

So are you thinking a lower gyro filter = higher d? As it is auto-tune put it at the lowest it could.

I already dropped auto-tune min d to .0005 in prep for another at session

This is a play quad. I can do what ever with it to test

Servers by jDrones