Tuning a 10kg frame with 29 inch props

I reached very good results on PID-tuning with valuable help from @Leonardthall, as described here: PID tuning of a heavier 10kg quadcopter

To test other variants of prop motor combinations we liked to test a real huge 29 inch prop on the same frame. Of course, we intend to tune it the same way, as described in the thread mentioned above. But I wonder, what would be a good starting point to do the PID-tuning? Should we go back to the ArduCopter standard PID’s?

1 Like

Start off with the same values you have after your tune but look for any sign of oscillation on your first start up.

If you are concerned reduce the rate pid values by 25%.

Then repeat the process you went through before.

Dear Leonard

It didnt worked at all with AutoTune while changing from
18.5x6.3 on a 435kv Motor with 6S who rotates on 4400RPM
to a
29 x 9.5 on a 170kv T-Motors U8 with 6s who did slow rotate at 1800RPM
The new motor on low KV was getting out of sync and did nearly lead to a crash. With finishing AutoTune, I recoverd the copter to a not real severe ground impact.

Ok, on the arducopter autotune pagehttp://ardupilot.org/copter/docs/autotune.html they war about low kv motors with ESC who get out of sync.

On the other hand, it seems to be possible to do so, see https://diydrones.com/forum/topics/autotune-successfull-on-low-kv-motors-heavier-quads-advice?id=705844%3ATopic%3A2221903&page=2#comments

Are there some settings to preadjust, so it could work with AutoTune?

I got REAL good results on AutoTune before, so therefore I do not resign to early to try AutoTune even on a low kv low RPM heavier Quadcopter…

Any help?

Best wishes, Severin

1 Like

I’m not an expert, but IMHO the aircraft is under powered.

Looking at the test data for a U8-170Kv motor, hover thrust (50% throttle) is 1.93 kilos. Ideally, you need a hover thrust per motor of 2.5 kilos.

Extrapolating a little, I’d guess the aircraft is hovering at 60+% throttle.

Because the last 5% of total throttle range does not produce any appreciable thrust, subtracting 5% from the top end we get an effective control range above hover throttle of about 35%. For an aircraft this heavy, that remaining 35% most likely isn’t enough for Pixhawk to use to maintain stability. Another factor is prop inertia, and I believe this is why the motors are going out of synch…

With that being said, I believe you are using the wrong frame. If you look at a Hex with those same motors and props you could lift 11.58 kilos at 50% throttle.

If the actual aircraft weight with a 12000mAh 6S battery was 10 kilos, you would get a flight time using 80% of the battery capacity that is in excess of 18 minutes.

And you also mentioned “out of Sync”

Have you put your throttle on a switch and tested for sync issues?

If your motors get out of sync I would not consider using the ESC/Motor combination.

Regarding power; I think the copter is in a good range. I need only 40% throttle to hoover:

Regarding sync - maybe its the wrong description. I dont know, if it is a sync problem between esc and motor.

I can assume, that the P-Values have been just to sharp for autotune with AutoTune aggressiveness on max (0.1) and Rate Roll /Pitch Values on 1.8.

Maybe I should try again with AutoTune Aggr on 0.5 and _P on 1.0?

Your lucky it didn’t flip itself into the ground as happened when I forgot to change the Filter and Aggr settings on a large Octo.

Just set the Aggr to min and take your filters down to 10 or even 8.

Start from there and work your way up.

It’s a known problem large props (heavy) and low kv motors, you can try lower diameter or up voltage and see what happens, tuning can be a maze wihtout exit in this case.
Edit: I forgot esc… thinking are compatible with motors, try lower timing and up start power, do some tests before tuning.

Hi Severin,

Can you provide the log of Autotune where you thought you saw the sync loss. I will have a look.

What ESC are you using?

Have you done any bench testing to check for sync loss?

Chat soon.

Hi Guys,

Just a quick chime in. I just finished tuning a 15+ kg hexa with 30’ props and 12s100kv motors. Filters at 6 and autotune aggressivity 0.05.
Is was a little frightening at the first, but autotune went through nicely and got a very well locked in beast. So I can confirm that it is possible to autotune heavy lifters as well.

Thanks to Leonard for providing all the info above.

1 Like

Thanks Eosbandi,

So just to reiterate to eveybody.

You should make sure your initial tune is good enough to recover from the disturbance that Autotune creates.

So start with a manual tune, check the stability, then do autotune.

Thank you Leonard and Andreas
I definitely will try that! As soon as the weather is better and the winds are gone.
As my copter has not 15 but 11kg, I’ll try with a ATC_RAT_RLL_FILT and ATC_RAT_PIT_FILT to 8Hz. Tune manually again first, then AutoTune with agressiveness on 0.05

Thanks for your advises. I’ll let you know how it works.

Here is one lesson that I learned from testing non-standard drive setups and probably crashing more than a dozen of prototypes: never ever think about a first flight with a certain drive setup if you did not ensure on the test bench that there is no possible input signal that can stall the drive.

I use a hacked ArduCopter firmware for that purpose that is able to replay bin logs, plus a python script to generate arbitrary signal forms. Most promising patterns are step functions between rather low and rather high output levels (not necessarily 0->100%, but also things like 30% -> 80%). Some drives even desync when decelerating. Be careful when doing these tests - I have broken a few props, especially larger ones.

If certain drive setup survives this kind of torture, I replay logs containing severe oscillations, with different frequencies (recorded with different airframes). For some reason, this seems to trigger sync losses even if the step functions don’t - may be this is the reason why AutoTune is so good at triggering a sync loss.

And here are the bad news: even if a drive is impossible to stall on the bench, there is still a slight chance to see a stall in the air due aerodynamic loads. But this will definitely need more than just AutoTune :wink:


Perhaps we should pull this out to be more generally available?


Hi Peter,

Sorry, what are you suggesting here?


For the SkyViper stuff tridge added a motor-test mode where it would
replay motor outputs based on a compile-time #include of prepared data.

Sounds like Holger wrote much the same thing, which isn’t a great use of
people’s time. Pulling tridge’s stuff out of the toy mode loops should be
possible - or perhaps some mish-mash of Holger’s and the current in-tree


Until today I was not able to get an Autotune done by my 29inch T-Motors Setup. Your advises dint help. I tried ATC_RAT_RLL_FILT and ATC_RAT_PIT_FILT down to to 5Hz and AutoTune with agressiveness on 0.05. Maybe I should reduce ANGLE_RATE_MAX (controls the maximum requested rotation rate in the roll and pitch aixs (default is 18000 (180deg/sec)) to 12000 or less?
I tuned the copter manually to a not to bad level, but would be still be very interested to get it running, since I have to do a lot more tuning work on similar frames in the near future. And manual tuning is realy time consuming. Anyone?

Do you have a log I can look at?

I was running 5hz on my 17kg x8, but Leonard said to go back to 20. Any thoughts Leonard? Just heading back out to re tune everything as I change my setup from U8170kv on 8s to U8II’s, Alpha FOC esc’s and 12s along with 28" folding Tmotor props.

Sorry but I don’t recall the conversation where I told you to do that but I suspect it was because I was seeing strange issues with Autotune responses that may be caused by excessive delay caused by low filter settings.

My general approach is to set the filter as low as possible until it starts to impact the results of autotune. I really need to add some system identification code to make it easier to define these filter frequencies with confidence.