Trying to set up a RPlidar A2 for obstacle avoidance, I cannot find PRX_TYPE parameter in mission planner

Hello All,
I am configuring a rover for obstacle avoidance with the RPLidar A2, I am using rover 4.1.0 official on fmuv2 hardware (pixhawk) and Mission Planner 1.3.75 (lastest, I think).
I have the stupid problem that I cannot find PRX_TYPE or any PRX_* parameters in the full parameter list of Mission Planner. I guess that setting PRX_TYPE = 5 is still necessary, as configuring SERIAL1_PROTOCOL = 11 (lidar360) does not specify a particular lidar model.

Any help will be much appreciated. Thanks,

1 Like

Hello again, I’ll reply myself,
I have found this thread Rover-4.1.0-beta4 released for beta testing - #10 by andyp1per saying that PRX parameters were removed in 1MB boards. I have an original Pixhawk and somewhere read that has 2MB flash, so I thought that was not the problem. But I have read now elsewhere that only 1MB is “usable” in those fmuv2 boards, so clearly that solves the mistery.
I am wondering now if I can use the RPlidar A2 to do obstacle avoidance in my pixhawk, anyhow.
Thankyou in advance and regards,

UPDATE: the pixhawk can be flashed as fmuv3, problem solved! sorry for the post

1 Like

Great that you figured this out. I’ve also found that some older Pixhawks are running the “fmuv2” firmware which is 1MB limited but the board can actually run the newer Pixhawk1 firmware (or “fmuv3”) and the full 2MB of flash is available. In general it is better to use the “Pixhawk1” firmware rather than the “fmuv2” or “fmuv3” although in this case it won’t actually make a difference.

1 Like

Same problem here with a Mini-Pix (Radiolink) and Ardurover 4.1.3 (official), may be it’s an stupid question but do you know if it can be flashed with any other firmware to get those params enabled?


Hi! I understand that, if the board has only 1MB of flash, obstacle avoidance won’t fit and it is disabled.
Missing features are listed in: Firmware Limitations on AutoPilot Hardware — Copter documentation
But I think I read somewhere that they were considering including OA in 1MB boards, maybe you can choose it somehow, I don’t know. In any case, I guess that if you build the sources, you can force it to be included.
Good luck!

1 Like

In AP 4.2 we have a “custom build server” that allows the user to specify which features are included/excluded. The server actually already exists but I’m afraid I don’t know what the URL is.

@peterbarker do you know the URL to the build server?


You could have other problems with Radiolink boards:
Radiolink not recommended

Hi everyone, I had reported this problem since August 21. I also tried with the latest stable but the PRX_TYPE parameter is not found because I’m using a F4 pro 1MB flash omnibus. I again generated a custom fw (4.2 dev) with the server and actually the PRX_TYPE parameter is present this time. However, nothing changes compared to the past: the sonarrange reading is correct with the lidar TF luna beneweke but the Simple Avoidance does not work either.
It has been reported here, but as it stands, it still doesn’t work.

@rmackay9 @rishabsingh3003