Trying to figure out why controller isn't picked up by Pixhawk/Mission Planner (solved)

Hello, I am using a PPM-enabled transmitter/receiver ( and I can’t get the transmitter to show in Mission Planner.

The PPM pins are connected to the Pixhawk’s RC pins in the right order (on receiver, white wire up, on Pixhawk, black wire up). I know the transmitter connects to the receiver because the light goes solid and I’ve tested the motors by plugging the receiver directly into the ESCs. I’m very new to drones so I’m probably doing something simple wrong, but I’m having trouble finding out what. Any advice? Thank you.


Edit: I figured it out!!! The receiver was not in the right mode. I started reading the receiver’s documentation and figured out how to get it into PPM mode.

Good work.
Feel free to yell out if you have any other difficulties or just questions.

I am now working on another problem if you have a moment :slight_smile:
I have performed the ESC calibration but I’m still not able to get the motors to move from the transmitter. I’ve messed with the ESC calibration screen and might’ve messed up the settings. I’ve also tried to do ESC calibration the other way putting the joystick up, connecting the battery, disconnecting the battery, etc. but just nothing happens. I did exactly what the person in the YouTube video did with a different result. I’m just not sure what to do because Mission Planner is reading my transmitter’s controls but the motors seem to plain old just not move! And yes I press the safety switch so it goes solid.

Are the motors working with the motor test function in Mission Planner?

Nothing happens when I press Test motor A, B, etc. or Test all motors. I tried changing the throttle % from 5 to 50 to 90 but nothing happened.

When you plug in the battery do you get the tones from the ESCs?

As Allister aludes to, just do all the calibrations and things as you have, then use MissionPlanner motor test to check motor order and spin.
In that test when you do all in sequence, or select any individual motor, the test uses the LETTERS not the numbers
You might need to set these to avoid using the arm/disarm safety switch - somewhat misnammed because reaching in amongst props to get to a “Safety” switch may not be very safe!

The theory being that if there’s RC input and motors work in testing, then it stands a good chance of flying. Using the RC to directly control the motors doesnt work as expected and often doesnt work at all.

Without props on, you can arm in Stabilise mode, apply a small amount of throttle. Holding the quad by hand you should be able to pitch and roll gently and observe motors on the lower side speed up (to lift that side if they had props on)

Thank you for the help. I hear tones from all the ESCs when I plug in the battery. But nothing seems to happen when I try ESC calibration using either method (from Mission Planner or the transmitter). I feel I must have messed up the settings for the ESCs like in the image I posted above.

set the Output PWM min and max to 1000 and 2000
Actually check in the full parameter tree to see if they already are.
it should be like this:

ESC calibration wont be crucial. Some have reported it not working lately and I havent had a chance to test it myself.
I use this semi-automatic method:

Thank you all works now I appreciate all of your help.

1 Like

Did you get the ESC calibration to work?

Yes that had worked prior so I haven’t touched it.